Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231960 - /etc/lvm/.cache file contains /dev/cdrom and other readonly devices.
Summary: /etc/lvm/.cache file contains /dev/cdrom and other readonly devices.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: John Feeney
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 08:27 UTC by Shyam kumar Iyer
Modified: 2010-01-12 03:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-11 15:54:57 UTC


Attachments (Terms of Use)

Description Shyam kumar Iyer 2007-03-13 08:27:10 UTC
Description of problem:
/etc/lvm/.cache file contains /dev/cdrom and other readonly devices. Because 
of this lvdisplay throws up errors on the console and dmesg. The errors seen 
are like this -
"ide: failed opcode was: unknown
hda: packet command error:  status=0x51 { AbortedCommand SeekComplete Error }
hda: packet command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }"

Version-Release number of selected component (if applicable):
lvm-2.02.16-3.el5

How reproducible:
Often

Steps to Reproduce:
1.Perform CD install.
2.Issue lvscan command or lvdisplay command.

 Actual results:
Read only errors and other errors mentioned in the described in the 
description are observed in the dmesg.

Expected results:
/etc/lvm/.cache should not contain devices like /dev/cdrom.

Additional info:
On issuing vgscan the cache file gets regenerated and does not contain 
the /dev/cdrom devices. This solves the issue.

Comment 1 Shyam kumar Iyer 2007-03-16 10:30:35 UTC
Please replicate the documentation for rhel5 also as mentioned in this 
knowledgebase article.
http://kbase.redhat.com/faq/FAQ_85_5834.shtm

Comment 3 Charles Rose 2007-06-07 04:48:44 UTC
A document fix as mentioned in Comment #1 would suffice to close this issue.

Comment 4 Charles Rose 2007-08-02 13:33:31 UTC
Larry, Please document this issue in a kbase article.

Comment 5 Larry Troan 2007-08-29 17:56:55 UTC
Per comment #1, this is already a KBase article:
http://kbase.redhat.com/faq/FAQ_85_5834.shtm

I've requested that the article include RHEL5 (rather than just RHEL4).

Comment 6 John Feeney 2007-11-01 21:10:14 UTC
It looks to me as though the RHEL4 kbase article was been updated to reference
RHEL5, too. (Thanks Larry and Gary.) I would ask Dell to make sure it meets
their expectations and if so, we can close this one out. 

Comment 7 Shyam kumar Iyer 2007-11-02 12:14:47 UTC
Yes, the kbase satisfies the expectations.

Comment 8 John Feeney 2007-11-02 14:32:21 UTC
Okay, closing it. 


Note You need to log in before you can comment on or make changes to this bug.