Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231932 - Debug info doesn't show up in sysprof
Summary: Debug info doesn't show up in sysprof
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 02:38 UTC by Rui Matos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-13 06:00:12 UTC


Attachments (Terms of Use)
sysprof profile demonstrating the problem (deleted)
2007-03-13 02:38 UTC, Rui Matos
no flags Details

Description Rui Matos 2007-03-13 02:38:02 UTC
Description of problem:
While doing some profiles I noticed that sysprof doesn't display the debuginfo
for the X server although I have xorg-x11-server-debuginfo-1.1.1-47.7.fc6
installed. I'm filling this on xorg-x11-server and not on sysprof since for
other packages it seems to be working (gtk, pango, etc.)

Version-Release number of selected component (if applicable):
xorg-x11-server-debuginfo-1.1.1-47.7.fc6
sysprof-1.0.8-1.fc6

How reproducible:
Always

I'm attaching a sysprof profile where one can see that X show up as only:

??? [/usr/bin/Xorg]

Comment 1 Rui Matos 2007-03-13 02:38:03 UTC
Created attachment 149896 [details]
sysprof profile demonstrating the problem

Comment 2 Rui Matos 2007-03-13 02:56:36 UTC
It seems that /usr/bin/Xorg has some strict permission bits:

-rws--x--x 1 root root 1820836 Fev 28 21:34 /usr/bin/Xorg

which would explain why sysprof can't read the data. But still, after I changed
those bits to:

-rwsr-xr-x 1 root root 1820836 Fev 28 21:34 /usr/bin/Xorg

I still don't obtain X info on profiles.


Comment 3 Søren Sandmann Pedersen 2007-03-13 06:00:12 UTC
Sysprof also needs the ability to read /proc/<pid-of-xserver>/maps, so you have
to run it as root to get information about the X server.

(But we should stop installing the X server binary read-only - those bits are
not exactly secret ...)



Note You need to log in before you can comment on or make changes to this bug.