Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231916 - paps output not displayed by evince
Summary: paps output not displayed by evince
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: paps
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 231971
TreeView+ depends on / blocked
 
Reported: 2007-03-12 23:08 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.6.6-19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 13:29:06 UTC


Attachments (Terms of Use)
postfix output (deleted)
2007-03-13 09:02 UTC, Patrice Dumas
no flags Details

Description Patrice Dumas 2007-03-12 23:08:35 UTC
Description of problem:

paps result is not displayed by evince or gv.

Version-Release number of selected component (if applicable):

paps-0.6.6-18.fc7

How reproducible:

always

Steps to Reproduce:
1.
echo AAA > t.txt
2.
paps t.txt > t.ps
3.
evince t.ps

Actual results:

ERROR: /undefined in 0,001000
Operand stack:
   (AAA)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   %loop_continue  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1122/1686(ro)(G)--   --dict:0/20(G)--   --dict:103/200(L)--  
--dict:27/29(L)--   --dict:7/11(L)--   --dict:13/18(L)--   --dict:3/3(L)--
Current allocation mode is local
Last OS error: 2
ESP Ghostscript 815.03: Unrecoverable error, exit code 1

** (evince:18421): WARNING **: Interpreter failed.


Expected results:

no error.

Additional info:

Looking at the stack trace seems like it is a ghostscript
trace in both cases. So maybe the error is in ghostscript,
but I doubt it since it also happens on Centos4.

Comment 1 Akira TAGOH 2007-03-13 01:42:29 UTC
I'm sorry but it works for me.
Can you provide me some information, such as your locale, the versions of
ghostscript, pango, all the fonts packages installed. also attach your t.ps into
bugzilla, please. the result of fc-match {Sans,Serif,Monospace} would be helpful
too.

Comment 2 Patrice Dumas 2007-03-13 09:01:02 UTC
locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


ghostscript-8.15.3-7.fc7
pango-1.16.0-1.fc7


urw-fonts-2.3-6.1.1
xorg-x11-fonts-misc-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7
bitmap-fonts-0.3-5.1.2.fc7
artwiz-aleczapka-fonts-1.3-5.fc6
xorg-x11-fonts-base-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
bitstream-vera-fonts-1.10-7
xorg-x11-fonts-truetype-7.1-3.fc7
dejavu-lgc-fonts-2.15-1
libdockapp-fonts-0.6.1-2.fc7
mplayer-fonts-1.1-4.lvn6
xorg-x11-fonts-75dpi-7.1-3.fc7
tetex-fonts-3.0-36.fc7
xorg-x11-font-utils-7.1-2
xorg-x11-fonts-100dpi-7.1-3.fc7
ghostscript-fonts-5.50-16.fc7
xorg-x11-fonts-Type1-7.1-3.fc7


$ fc-match Sans
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"
$ fc-match Serif
DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"
$ fc-match Monospace
DejaVuLGCSansMono.ttf: "DejaVu LGC Sans Mono" "Book"


Comment 3 Patrice Dumas 2007-03-13 09:02:36 UTC
Created attachment 149910 [details]
postfix output

Comment 4 Patrice Dumas 2007-03-13 09:05:51 UTC
(In reply to comment #3)
> Created an attachment (id=149910) [edit]
> postfix output

postscript output ;-) (to be clear, I use esmtp ;-).

Comment 5 Akira TAGOH 2007-03-13 10:23:42 UTC
Ok, thank you for your info. well, the problem is that the style of the real
number is changed against your locale. PostScript doesn't affect such numeric
formats from locale in its syntax as well as other script languages.

For your workaround till this get fixed, set LC_NUMERIC=C and run paps would works.

Comment 6 Markku Kolkka 2007-03-24 10:35:37 UTC
paps-0.6.6-18.fc6 has the same bug, preventing printing of plain text files from
the command line in Fedora Core 6.

Comment 7 Akira TAGOH 2007-03-27 11:57:43 UTC
Fixed in paps-0.6.6-19

Comment 8 Patrice Dumas 2007-04-09 13:29:06 UTC
I can confirm that it is fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.