Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231915 - Bad: Installer crashed & bugzilla site sluggish on my end.
Summary: Bad: Installer crashed & bugzilla site sluggish on my end.
Keywords:
Status: CLOSED DUPLICATE of bug 231771
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 23:08 UTC by Shawn Hill
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 22:00:46 UTC


Attachments (Terms of Use)

Description Shawn Hill 2007-03-12 23:08:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070226 Fedora/1.5.0.10-1.fc6 Firefox/1.5.0.10 pango-text

Description of problem:
Component: Software Manager
Summary: TB6d0a67a4 __init__.py:171:simpleDBInstalled:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 351, in _groupSelected
    self.__setGroupDescription(grp)
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 368, in __setGroupDescription
    if self.ayum.isPackageInstalled(p):
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 185, in isPackageInstalled
    installed = self.simpleDBInstalled(name)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 171, in simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
TypeError: rpmdb open failed

Local variables in innermost frame:
self: <__main__.PackageManager object at 0x8f3fbac>
name: lockdev-devel


Version-Release number of selected component (if applicable):
read description and steps to reproduce.

How reproducible:
Didn't try


Steps to Reproduce:
1. Used add/remove software to add development packagess.
2. Computer rebooted during update probably due to intermittant bad power connection.
3. Restarted step 1, then got above message.
4. Got here and couldn't select component because the menu kept jumping back to the top and wouldn't respond properly, (did this twice with same result). Couldn't select fc6 because of same problem. Typing on this page is even sluggish!

Actual Results:
Read above!

Expected Results:
Packages should have installed and site shouldn't be sluggish on my end.

Additional info:
Component: Software Manager
Summary: TB6d0a67a4 __init__.py:171:simpleDBInstalled:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 351, in _groupSelected
    self.__setGroupDescription(grp)
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 368, in __setGroupDescription
    if self.ayum.isPackageInstalled(p):
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 185, in isPackageInstalled
    installed = self.simpleDBInstalled(name)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 171, in simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
TypeError: rpmdb open failed

Local variables in innermost frame:
self: <__main__.PackageManager object at 0x8f3fbac>
name: lockdev-devel

Comment 1 Thomas Woerner 2007-03-13 09:43:04 UTC
Assigning to pirut

Comment 2 Jeremy Katz 2007-03-19 22:00:46 UTC

*** This bug has been marked as a duplicate of 231771 ***


Note You need to log in before you can comment on or make changes to this bug.