Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231907 - Recent update broke trac
Summary: Recent update broke trac
Keywords:
Status: CLOSED DUPLICATE of bug 231836
Alias: None
Product: Fedora
Classification: Fedora
Component: trac
Version: 6
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 22:06 UTC by Jonathan S. Shapiro
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-13 00:18:06 UTC


Attachments (Terms of Use)

Description Jonathan S. Shapiro 2007-03-12 22:06:43 UTC
I don't know if this is a trac bug or a bug in something else that was recently
updated. What I do know is that my trac install from FC6/extras was working fine
on Friday afternoon, and has ceased working now. Attempts to load the "project
list" page give a NULL result without error in PyObject_Call. Attempts to load
any other page give a complaint of a misconfiguration. This appears to be
generated by apache, not by trac.

The install is using mod_python and sqlite, and I see that a similar problem has
been reported elsewhere that seems to implicate something in the sqlite subsystem.

The install is also using selinux, but I tried changing that to permissive and
the error still appears.

Sample of the bug can be see at /trac at office_ dot eros-os_ dot com (remove
the underbars), and the longer message at /trac/coyotos on the same machine.

I will do anything necessary/helpful to try to track this down. We are utterly
hosed until this is resolved. I'ld back out the bad update, but I don't know
what update was the culprit. If somebody can give me a way to look at the recent
update history I'm willing to try backing things out one at a time.

Comment 1 Jeffrey C. Ollie 2007-03-13 00:18:06 UTC
The bug isn't directly in trac, it's in python-sqlite2 that got pulled in with
the 0.10.3.1-1 release of trac.  There appears to be a bug in python-sqlite2
that doesn't like running under mod_python when mod_cache is also loaded.  The
easiest fix is to remove python-sqlite2.  I've built a -2 version of the trac
package that  doesn't have a dependency on python-sqlite2 but it doesn't appear
to have been pushed out to the mirrors so for now you'll have to use --nodeps to
remove python-sqlite2.

*** This bug has been marked as a duplicate of 231836 ***

Comment 2 Jonathan S. Shapiro 2007-03-13 04:07:14 UTC
Just wanted to confirm that doing a rpm -e --nodeps on python-sqlite2 resolves this.


Note You need to log in before you can comment on or make changes to this bug.