Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231900 - obsoletes handling doesn't account for arch
Summary: obsoletes handling doesn't account for arch
Keywords:
Status: CLOSED DUPLICATE of bug 200643
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-03-12 21:04 UTC by Nalin Dahyabhai
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 19:24:36 UTC


Attachments (Terms of Use)

Description Nalin Dahyabhai 2007-03-12 21:04:19 UTC
Attempting to update to a recent Raw Hide snapshot, I see this:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 nautilus-sendto         i386       0.10-1.fc7       development        79 k
     replacing  nautilus-sendto-bluetooth.x86_64 0.8-4.fc7

 nautilus-sendto         x86_64     0.10-1.fc7       development        82 k
     replacing  nautilus-sendto-bluetooth.x86_64 0.8-4.fc7

I don't have the i386 nautilus-sendto-bluetooth installed, so installing the
i386 nautilus-sendto seems kinda wrong.

Comment 1 Jeremy Katz 2007-03-19 22:00:29 UTC
This has come up before and I think the actual behavior has flip-flopped over
time...  given that the obsolete doesn't specify an arch (it can't really), what
the "right" thing to do is hard to say.  By installing both arches, it's
consistent with if you just did the install... but not with an update.  I guess
it probably makes more sense to follow the update path.

Comment 2 Jeremy Katz 2007-04-25 19:24:36 UTC

*** This bug has been marked as a duplicate of 200643 ***


Note You need to log in before you can comment on or make changes to this bug.