Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231857 - HTS 31 memory test w/ 128GB hangs system
Summary: HTS 31 memory test w/ 128GB hangs system
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 16:41 UTC by Jeff Svatek
Modified: 2008-07-16 21:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 16:55:10 UTC


Attachments (Terms of Use)
Memory Log (deleted)
2007-03-12 16:41 UTC, Jeff Svatek
no flags Details
Passing HTS 26 Mem Log (Won't upload though) (deleted)
2007-03-12 20:30 UTC, Jeff Svatek
no flags Details

Description Jeff Svatek 2007-03-12 16:41:29 UTC
Description of problem:
HTS 31 memory test w/ 128GB hangs system

Version-Release number of selected component (if applicable):
HTS 30, 31

How reproducible:
Everytime

Steps to Reproduce:
1.Install RHEL5x64 (non-xen kernel)
2.Install HTS 31 and dependencies
3.Run memory test "hts certify --test memory"

  
Actual results:
System freezes @
...
53998.52 3414.18
107998.09 3038.22
done.
Starting Threaded Memory Test
running for 100% of RAM


Expected results:


Additional info:

Comment 1 Jeff Svatek 2007-03-12 16:41:29 UTC
Created attachment 149838 [details]
Memory Log

Comment 2 Jeff Svatek 2007-03-12 20:29:30 UTC
I got a passing run using hts 26.  Unfortunately when I tried to package it, it 
gave me an error about "getcwd: cannot access parent directories: No such file 
or directory."  This was different than the previous error submitted by Dell 
that we were seeing with this version kit usually.  I ran the patch on the logs 
and it gives a similar error about getcwd.  Anyways, I have a passing rpm but 
it won't upload as it says there are no tests runs after I attempt to use the 
R26 patch.  I attached the rpm.  

Comment 3 Jeff Svatek 2007-03-12 20:30:39 UTC
Created attachment 149860 [details]
Passing HTS 26 Mem Log (Won't upload though)

Comment 4 Greg Nichols 2007-03-13 00:24:52 UTC
Please try running threaded_memtest directly.  It can be found in
/usr/share/hts/tests/memoryre

make threaded_memtest
./threaded_memtest -qpv -m100% -t10

Attach the results.

Thanks!

Comment 5 Jeff Svatek 2007-03-16 19:29:35 UTC
Ok, I will try and run this soon.  Please let me know of any updates to the test
kit or other things to try.

Comment 6 Jeff Svatek 2007-03-27 14:52:04 UTC
We are considering the possibility that this is a single unit failure.  I will
keep you informed about our findings.

Comment 7 Greg Nichols 2007-04-10 16:55:10 UTC
Closing as a hardware issue


Note You need to log in before you can comment on or make changes to this bug.