Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231853 - PPP causes a kernel crash
Summary: PPP causes a kernel crash
Keywords:
Status: CLOSED DUPLICATE of bug 231850
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: 5
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 16:13 UTC by 260795
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-30 08:24:55 UTC


Attachments (Terms of Use)

Description 260795 2007-03-12 16:13:55 UTC
Description of problem: 

We've found a replicable situation where pppd causes a kernel crash. First of 
all a bit of framework. 

We use pppd to provide remote support to some of our customers. Every customer 
has a personal account to connect to our server using PPP. The firewall on 
these accounts is configured so that we can connect back to their servers and 
check for problems, but the remote server has basicly no access at all to our 
network.

Since few weeks one of these customers caught a virus or a dialer (it uses a 
windows based server) which tries to connect to our server using the RAS entry 
configured for remote support, probably thinking it is an Internet connection. 
The RAS entry has the password saved, so that the virus is able to authenticate 
against our server, even though it isn't able to do anything else because of 
the configured firewall.

So far nothing wrong, by the way sometimes the virus is able to bring our 
server down because of a kernel crash. I haven't been able to save the kernel 
OOPS on screen but it clearly reported that the problem was caused by ppp. I 
have a log of the debug PPP session as saved by pppd (see attachemnt). We will 
further investigate to try to identify the virus or the dialer and may be catch 
the kernel OOPS.

Version-Release number of selected component (if applicable): ppp 2.4.3-6.2.1, 
kernel-smp 2.6.17 1.2157_FC5

How reproducible: difficult to reproduce

Steps to Reproduce: you need an infected windows pc, more info to be gathered
  
Actual results: kernel crash

Expected results: normal connection but no kernel crash and everything filtered 
out by the firewall

Additional info: none

Comment 1 260795 2007-03-12 16:15:30 UTC
Sorry, duplicated by mistake. See bug 231850.

Comment 2 Thomas Woerner 2007-08-30 08:24:55 UTC

*** This bug has been marked as a duplicate of 231850 ***


Note You need to log in before you can comment on or make changes to this bug.