Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231848 - python-sqlite2-2.3.2 conflicts with Apache's mod_cache
Summary: python-sqlite2-2.3.2 conflicts with Apache's mod_cache
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-sqlite2
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dawid Gajownik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 232025 232784 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 15:45 UTC by Matthew Gillen
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 2.3.3-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 01:08:18 UTC


Attachments (Terms of Use)

Description Matthew Gillen 2007-03-12 15:45:59 UTC
Description of problem:
This link describes some conflicts that the 2.3.2 version of python-sqlite2 has
with mod_cache:
 http://initd.org/tracker/pysqlite/ticket/146

Version-Release number of selected component (if applicable):
python-sqlite2-2.3.2

How reproducible:
This should affect any python-based cgi scripts, but I'm having specific
problems when using it with Trac.

The link above indicates that this problem is fixed upstream already, in version
2.3.3.

Comment 1 Dawid Gajownik 2007-03-13 18:19:09 UTC
Thanks for your bug report!

Sorry that I did not update this package earlier - I had lots of exams and
forget about new version :/

I just pushed new packaged through buildsystem (devel, FE-6 and FE-5) so they
should be available shortly:
http://buildsys.fedoraproject.org/build-status/job.psp?uid=29229
http://buildsys.fedoraproject.org/build-status/job.psp?uid=29230
http://buildsys.fedoraproject.org/build-status/job.psp?uid=29231

I haven't decided yet, but presumably python-sqlite2 will be removed from
rawhide because pysqlite2 was merged into python 2.5.

BTW My friend already tested this package and his trac installation works fine
now ;]

Comment 2 Jonathan S. Shapiro 2007-03-13 18:32:05 UTC
Just a word from one of the people impacted by this: thank you for the prompt
attention that you gave it. As I'm sure you can imagine, losing your tracking
and wiki system when you are trying to run a tight development effort is unsettling.

So anyway, thanks!

Comment 3 Dawid Gajownik 2007-03-13 19:01:20 UTC
(In reply to comment #2)
> As I'm sure you can imagine, losing your tracking
> and wiki system when you are trying to run a tight development effort is
unsettling.

If you can't wait for the new package you can use this ugly workaround:

rpm -e --force python-sqlite2

Trac should work correctly with python-sqlite. I hope that I did not
significantly slowed down development of Coyotos. I've been eagerly waiting for
Hurd on Coyotos (persistency and other nice features come to my mind) ;)


Comment 4 Jonathan S. Shapiro 2007-03-13 19:41:05 UTC
Already applied that workaround, but thanks. Nope, slowdown wasn't significant.
We lost about 4 hours of actual time.

Thanks again for the prompt response.

Comment 5 Joe Orton 2007-03-14 14:09:07 UTC
*** Bug 232025 has been marked as a duplicate of this bug. ***

Comment 6 Matthew Gillen 2007-03-15 01:08:18 UTC
The new version is now available in extras.  Thanks for the update.

Comment 7 Joe Orton 2007-03-19 10:21:19 UTC
*** Bug 232784 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.