Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231833 - yum 3.1.4 metadata handling
Summary: yum 3.1.4 metadata handling
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 13:36 UTC by Rahul Sundaram
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 19:52:37 UTC


Attachments (Terms of Use)

Description Rahul Sundaram 2007-03-12 13:36:37 UTC
Description of problem:

Yum seems to download both the xml.gz files as well as sqllite.gz files for the
same repo metadata

How reproducible:

Quite often.


Actual results:

# yum -d10  update
Loading "installonlyn" plugin
Running "config" handler for "installonlyn" plugin
Yum Version: 3.1.4
COMMAND: yum -d10 update 
Installroot: /
Setting up Update Process
Reading Local RPMDB
Building updates object
Setting up Package Sacks
primary.xml.gz                                                  815 kB 00:54 
developmen: ################################################## 2295/2295
primary.sqlite.bz2        100% |=========================| 2.0 MB    00:08     
http://fedora.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/extras/development/i386/repodata/primary.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2        100% |=========================| 2.0 MB    02:38     
putting glibc in complex update
putting openssl in complex update
putting kernel in complex update
processing glibc.i686
processing openssl
processing kernel.i686
No Packages marked for Update/Obsoletion


Expected results:

Just download the sqlite database if available or download the xml.gz file
otherwise.

Additional info:

Note that xml.gz file seems to less than half the sqlite database size

Comment 1 Jesse Keating 2007-03-12 19:52:37 UTC
Yum downloaded the primary.xml.gz file for development as that is all that is
available.  It downloaded primary.sqlite.bz2 for extras-development as that is
available there.  This is not a bug, and size comparing development repodata to
extras-development repodata isn't helpful.


Note You need to log in before you can comment on or make changes to this bug.