Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231820 - [Propose] Netdump verbose option
Summary: [Propose] Netdump verbose option
Keywords:
Status: CLOSED DUPLICATE of bug 231365
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: netdump
Version: 4.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 10:59 UTC by kenji kikuchi
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 14:15:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
my idea for changes (deleted)
2007-03-12 10:59 UTC, kenji kikuchi
no flags Details | Diff

Description kenji kikuchi 2007-03-12 10:59:15 UTC
Description of problem:

I would like to propose verbose option for netdump server. Currently, to make
sure if netdump has successfully finished, server administrators need to check
 - /var/crash/xxx/vmcore
 - /var/crash/xxx/log
 
I think it's not a easy step for the most of them, and administrators who set up
nedtump or take vmcore files are not always engineers who examine the vmcore files. 

In addition, these days, most of servers have an ASR (Automatic System Recovery)
function. ASR itself has the ability to restart the crashed system. I also
think, it's making server administrators' netdump works more difficult.

Also, these days, most of servers have large memory capacity, and putting lots
of physical memory makes netdump memory transmission process longer. 

I think if netdump server could list how much memory page has been successfully
received so far, and write logs when it send restart command to the netdump
client, administrators can easily find how netdump is working without waiting
vmcore and log file creation.  


I think adding verbose option helps server administrators. I'm attaching a patch
file. This is against netdump-0.7.16. Please check the changes.



Version-Release number of selected component (if applicable):
RHEL4 update3, netdump-0.7.16

Comment 1 kenji kikuchi 2007-03-12 10:59:15 UTC
Created attachment 149814 [details]
my idea for changes

Comment 2 Neil Horman 2007-03-12 14:15:29 UTC

*** This bug has been marked as a duplicate of 231365 ***


Note You need to log in before you can comment on or make changes to this bug.