Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231797 (ati-x1400) - Vesa driver does not work with ati x1400
Summary: Vesa driver does not work with ati x1400
Keywords:
Status: CLOSED RAWHIDE
Alias: ati-x1400
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: rawhide
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
: 230700 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-12 01:54 UTC by Justin Conover
Modified: 2018-04-11 13:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 16:14:08 UTC


Attachments (Terms of Use)
Xorg.setup.log (deleted)
2007-03-12 01:54 UTC, Justin Conover
no flags Details
Xorg.0.log (deleted)
2007-03-12 01:59 UTC, Justin Conover
no flags Details
xorg.conf.new created from X -configure (deleted)
2007-03-13 02:44 UTC, Justin Conover
no flags Details
Xorg.0.log (deleted)
2007-03-23 00:58 UTC, Justin Conover
no flags Details

Description Justin Conover 2007-03-12 01:54:38 UTC
Description of problem: Vesa doesn't work on ati x1400 in rawhide or f7test2

Logs attached.

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-1.3.0-4.fc7


How reproducible:
Install f7t2

Steps to Reproduce:
1. Install f7t2
2. text install
3. text after install
  
Actual results:
Text

Expected results:
Graphics....

Additional info:
# kudzu -p -c VIDEO
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc Radeon Mobility X1400"
vendorId: 1002
deviceId: 7145
subVendorId: 1028
subDeviceId: 2003
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0

# lspci -vv

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400 (p
rog-if 00 [VGA])
        Subsystem: Dell Unknown device 2003
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 4
        Region 0: Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Region 1: I/O ports at ee00 [size=256]
        Region 2: Memory at dfdf0000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at dfd00000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot
-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <4us, L1 unlimited
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM L1 Enabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x16
        Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable
-
                Address: 0000000000000000  Data: 0000

Comment 1 Justin Conover 2007-03-12 01:54:40 UTC
Created attachment 149803 [details]
Xorg.setup.log

Comment 2 Justin Conover 2007-03-12 01:59:21 UTC
Created attachment 149805 [details]
Xorg.0.log

Comment 3 Matěj Cepl 2007-03-12 23:22:12 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Was this clean installation (i.e., there was no previous installation of Linux
on the same hard disk) or did you upgrade/re-install? Please attach your X
server config file (/etc/X11/xorg.conf) to the bug report as individual
uncompressed file attachment using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Justin Conover 2007-03-13 02:44:30 UTC
Created attachment 149897 [details]
xorg.conf.new created from X -configure

Comment 5 Justin Conover 2007-03-13 02:48:12 UTC
1.)  Yes, this was a new install.

2.)  No, there wasn't a xorg.conf because it wasn't created.  However, I
included one from doing "X -configure".

3.)  It wont run with it or with out it, also wont work with my xorg.conf from
Fedora Core 6.

Comment 6 Matěj Cepl 2007-03-13 16:37:10 UTC
*** Bug 230700 has been marked as a duplicate of this bug. ***

Comment 7 Justin Conover 2007-03-16 09:58:03 UTC
Any other information I can provide for this?

Comment 8 Justin Conover 2007-03-23 00:58:46 UTC
Created attachment 150710 [details]
Xorg.0.log

Comment 9 Adam Jackson 2007-03-23 16:51:18 UTC
(In reply to comment #8)
> Created an attachment (id=150710) [edit]
> Xorg.0.log

Wow.  I, hrm.

So, if I hack the vesa driver to always fail the first VBEValidateModes, I still
can't reproduce that.  And I'm not sure why the backtrace is missing from the
log there.  Any chance you can start X from an ssh session into the box to see
if there's additional output?

Comment 10 Adam Jackson 2007-03-27 16:14:08 UTC
AFAIK, and from email, xorg-x11-drv-vesa 1.3.0-5 should be working here. 
Marking as RESOLVED, but please do reopen if this pops up again.

Comment 11 Charles R. Anderson 2007-05-28 19:22:11 UTC
Please see bug #236416 which may be related.  There the issue is that EDID
coming from the BIOS is sometimes not read completely.


Comment 12 Ludek Smolik 2007-06-11 07:26:28 UTC
This is my report:
I am using Lenovo Z61m with Ati mobility X1400 card. 
1) It is not possible to install Fedora 7 on this laptop from iso images.
Display is black. Only way is network upgrade from Fedora Core 6 with
--exclude=xorg-x11-drv-vesa.
2 After upgrade from xorg-x11-drv-vesa-1.2.1-4.fc6 to
xorg-x11-drv-vesa-1.3.0.8.fc7 (from updates repository) it seems work fine, but
it  is not so stable with external CRC monitor.

Comment 13 Ludek Smolik 2007-06-11 10:24:07 UTC
(In reply to comment #12)
> This is my report:
> I am using Lenovo Z61m with Ati mobility X1400 card. 
> 1) It is not possible to install Fedora 7 on this laptop from iso images.
> Display is black. Only way is network upgrade from Fedora Core 6 with
> --exclude=xorg-x11-drv-vesa.
> 2 After upgrade from xorg-x11-drv-vesa-1.2.1-4.fc6 to
> xorg-x11-drv-vesa-1.3.0.8.fc7 (from updates repository) it seems work fine, but
> it  is not so stable with external CRC monitor.

And it is very unstable with Firefox 2.0.0.4 and Epiphany too.

Comment 14 Justin Conover 2007-06-11 13:56:21 UTC
See this bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241491

There have been updates that should fix the vesa driver for you.

Also, during the install you can drop out of X and edit your xorg.conf to have a
display of 800x600 and X should startup.


Note You need to log in before you can comment on or make changes to this bug.