Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231794 - Artist information, album information and lyrics tabs not being shown
Summary: Artist information, album information and lyrics tabs not being shown
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: exaile
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-11 22:44 UTC by Debarshi Ray
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 10:58:26 UTC


Attachments (Terms of Use)

Description Debarshi Ray 2007-03-11 22:44:27 UTC
Description of problem:


Version-Release number of selected component (if applicable):
0.2.8

How reproducible:
Every time.

Steps to Reproduce:
1. Start Exaile and play a song.
2. Go to View -> Information and click any of the three options: artist
information, album information, or lyrics. Otherwise use Ctrl+E (artist
information) or Ctrl+L (lyrics) to do the same thing.
  
Actual results:
The extra tab, alongside the 'playlist' tab, displaying the requested
information does not show up.

Expected results:
A new tab should be created, which should display the artist information, album
information, or lyrics of the currently playing tune. Usually the Wikipedia
entry of the artist or album is displayed; while the lyrics is obtained from a
different server

Additional info:
n.a.

Comment 1 Deji Akingunola 2007-03-12 02:57:49 UTC
I tested this with ver. 0.2.9b2, which is what I have currently installed, and
it works as expected. So this issue is probably fixed in 0.2.9; but I'm holding
back pushing the beta version for FC6 until the final 0.2.9 release is made
(expectedly  soon).

Comment 2 Debarshi Ray 2007-03-29 01:23:15 UTC
Exaile 0.2.9 has been released.  

Comment 3 Deji Akingunola 2007-03-29 01:30:31 UTC
(In reply to comment #2)
> Exaile 0.2.9 has been released.  

Yeah, it has already been built for Extras, should be available in the repo soon.

Comment 4 Debarshi Ray 2007-03-29 16:13:47 UTC
There was no bug in Exaile 0.2.8, since the issue is present in 0.2.9 too. This
is because Exaile needs gnome-python2-extras and gnome-python2-gtkhtml to
display the artist, album and lyrics information. In 0.2.10 gtkhtml will be
replaced by 'mozembed'.'

However while doing:
# rpm -Uvh exaile-0.2.9-1...
does not list any of the above mentioned packages as dependencies, even when I
did not have them installed. Maybe you could include them as depedencies, since
their absense take away some of the charm of Exaile.

Comment 5 Deji Akingunola 2007-03-29 19:58:07 UTC
If I understand you correctly, installing gnome-python2-gtkhtml make the bug
disappear for you? I'm going to add gnome-python2-extras and
gnome-python2-gtkhtml dependencies to exaile.

Comment 6 Debarshi Ray 2007-03-29 20:48:09 UTC
I am definite about gnome-python2-gtkhtml, but gnome-python2-extras needs some
more investigation.

Comment 7 Deji Akingunola 2007-03-30 06:11:15 UTC
New build with the dependencies should hit the mirrors soon.

Comment 8 Mamoru TASAKA 2007-03-30 06:13:33 UTC
For python related packages, I usually try the following
-------------------------------------------------------------
$ LANG=C grep -r 'import ' `rpm -ql foo` | grep -v Binary | sed -e 's|.*:||' |
sed -e 's|^[ \t][ \t]*||' | sort | uniq 
--------------------------------------------------------------

Comment 9 Mamoru TASAKA 2007-03-30 10:37:46 UTC
Please check the following

https://www.redhat.com/archives/fedora-devel-list/2007-March/msg01869.html

Comment 10 Deji Akingunola 2007-03-30 10:58:26 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.