Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231771 - unhandled exception in pirut, rpmdb open failed
Summary: unhandled exception in pirut, rpmdb open failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 218952 231915 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-11 14:29 UTC by ravrat
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 21:58:41 UTC


Attachments (Terms of Use)
log file generated (deleted)
2007-03-11 14:29 UTC, ravrat
no flags Details

Description ravrat 2007-03-11 14:29:04 UTC
Description of problem:
When i run software updater once, then run pirut, it creates an exception. 

Version-Release number of selected component (if applicable):


How reproducible:
run software updater, then let it update, then run add/remove programs. Running
software updater also produces an exception

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 ravrat 2007-03-11 14:29:04 UTC
Created attachment 149792 [details]
log file generated

Comment 2 ravrat 2007-03-11 16:38:45 UTC
i ran yum update from the shell line, and i get the following error
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run
database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
   idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed


Comment 3 Jeremy Katz 2007-03-19 21:58:41 UTC
This is fixed with later kernels.

Comment 4 Jeremy Katz 2007-03-19 22:00:50 UTC
*** Bug 231915 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2007-03-19 22:05:18 UTC
*** Bug 218952 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.