Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231737 - /usr/share/locale/be@latin/LC_MESSAGES is not owned
Summary: /usr/share/locale/be@latin/LC_MESSAGES is not owned
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-10 23:42 UTC by Robert Scheck
Modified: 2015-03-05 01:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-27 14:55:59 UTC


Attachments (Terms of Use)

Description Robert Scheck 2007-03-10 23:42:27 UTC
Description of problem:
The directory /usr/share/locale/be@latin/LC_MESSAGES is not owned by any 
package. It also looks to me whether "be@latin" is the same like "be" but
not with same charset etc. thus not provided by filesystem.

Version-Release number of selected component (if applicable):
glib2-2.12.11-1

How reproducible:
Everytime, see above.

Actual results:
/usr/share/locale/be@latin/LC_MESSAGES is not owned

Expected results:
Kill "be@latin" or clarify with Bill whether this directory should be added to 
the filesystem package. IMHO providing "be" and "be@latin" is unnecessary.

Comment 1 Bill Nottingham 2007-03-12 16:25:24 UTC
So, my question would be why we have:

sr@Latn
uz@Latn

but:

be@latin?

Comment 2 Robert Scheck 2007-03-12 16:30:45 UTC
I'm guessing because there's no standard anywhere regarding this. So When I 
would put rsc@mY$World" into some upstream package, this would get accepted
by downstream somehow surely, too.

Comment 3 Matthias Clasen 2007-03-24 05:32:54 UTC
glibc people prefer "latin" over "Latn". 

Comment 4 Robert Scheck 2007-03-24 23:10:06 UTC
Can we get these latin vs. Latn to one common style so that they can be owned 
by the filesystem package?

Comment 5 Matthias Clasen 2007-03-26 21:13:21 UTC
> IMHO providing "be" and "be@latin" is unnecessary.

This is not true. One is Belarussian in Cyrillic (the default), the other
is Belarus in Latin.

Moving to filesystem.

Comment 6 Robert Scheck 2007-04-28 14:54:00 UTC
Bill, ping?

Comment 7 Bill Nottingham 2007-05-01 04:40:32 UTC
We have an exception file for @modifier in filesystem; it would need to be added
there. Whether we want to simultaneously beat upstream into using latin instead
of Latn, I don't know.

Comment 8 Phil Knirsch 2008-03-27 14:55:59 UTC
Added be@latin to lang-exceptions for now.

Read ya, Phil



Note You need to log in before you can comment on or make changes to this bug.