Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231720 - Invalid / incomplete catagories field in several gnome-games .desktop files
Summary: Invalid / incomplete catagories field in several gnome-games .desktop files
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-games
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-10 18:35 UTC by Hans de Goede
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-11 08:19:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 417014 None None None Never

Description Hans de Goede 2007-03-10 18:35:57 UTC
Hi,

Short intro I'm a fedora contributer who is active in the games SIG, see:
http://fedoraproject.org/wiki/Extras/SIGs/Games
http://fedoraproject.org/wiki/HansdeGoede

As Games SIG, we are so successful at packaging games, that the
Applications->Games menu can become rather cluttered up. To fix this "problem"
I've created a package called games-menus. Which creates a number of submenus
under the Games menus based on the additional categories a .desktop file with as
main category Game may have, see:
http://standards.freedesktop.org/menu-spec/latest/apa.html

However some gnome-games games do not show up in the submenus (instead they stay
in the "main" Games menu) or show up in a strange submenu. This happens because
of missing or invalid additional categories in the .desktop files for these games.

To reproduce:
yum install games-menus

Goto your application menu and then:
* Iagno shows up directly under Games, should be under Games->Board Games
  Fix: add BoardGame to the categories

* Sudoku shows up directly under Games, should be under Games->Logic & Puzzles
  Fix: add LogicGame to the categories

* Tali shows up directly under Games, should be under Games->Card Games
  Fix: add CardGame to the categories

* Nibbles (aka snake) shows up under Games->Arcade, I have _never_ seen snake
  in an Arcade, should be under Games->Logic & Puzzles
  Fix: remove ArcadeGame from and add LogicGame to the categories

p.s. The categories field of a .desktop file can be modified by editing / 
patching it, but also with the --add-category / --remove-category options
of desktop-file-install. This has the advantage that you do not need to redo
patches when a change is made to the .desktop file(s).

Comment 1 Ray Strode [halfline] 2007-03-11 01:33:29 UTC
Hi Hans,

Bug seems reasonable to me, but it doesn't really make sense for fedora to do
--add-category/--remove-category etc.  Instead, would you mind filing upstream?
We can then just pull in the fixes in 2.18.1 or whatever.

Comment 2 Hans de Goede 2007-03-11 08:19:32 UTC
Filed upstream, external reference added, closing as upstream.


Note You need to log in before you can comment on or make changes to this bug.