Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231718 - Misplaced BuildRequires in kdeartwork-extras
Summary: Misplaced BuildRequires in kdeartwork-extras
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeartwork-extras
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-10 18:20 UTC by Kevin Kofler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-11 22:18:04 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2007-03-10 18:20:01 UTC
Description of problem:
kdeartwork-extras contains 2 BuildRequires which end up in the description of 
the -kxs subpackage:
BuildRequires: kdebase-devel >= 6:3.5.6
BuildRequires: libart_lgpl-devel
BuildRequires must be listed before any Summary tags. They are also per 
package, not per subpackage, so they have to be listed before the subpackages. 
The first one is a duplicate (it's also listed at the correct location), but 
the libart_lgpl one is rendered useless by this mistake.

Version-Release number of selected component (if applicable):
kdeartwork-extras-3.5.6-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Look at the description of kdeartwork-extras-kxs.
  
Actual results:
BuildRequires in the description.

Expected results:
BuildRequires in a place in the specfile where they're actually used by 
RPM. ;-)

Comment 1 Rex Dieter 2007-03-11 22:18:04 UTC
Looks like a botched copy-n-paste.  Thanks.

%changelog
* Sun Mar 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.5.6-3
- remove errant/misplaced BR's (#231718)


Note You need to log in before you can comment on or make changes to this bug.