Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231659 - yum groupinstall KDE... breaks setroobleshoot-server - too many open files
Summary: yum groupinstall KDE... breaks setroobleshoot-server - too many open files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 20:57 UTC by Doncho Gunchev
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-25 21:56:18 UTC


Attachments (Terms of Use)
yum error while 'yum -y groupinstall "KDE (K Desktop Environment"' (deleted)
2007-03-09 20:57 UTC, Doncho Gunchev
no flags Details
setroubleshoot's error? (deleted)
2007-03-09 21:36 UTC, Doncho Gunchev
no flags Details
successfull rpm -ihv... (deleted)
2007-03-09 21:38 UTC, Doncho Gunchev
no flags Details

Description Doncho Gunchev 2007-03-09 20:57:48 UTC
Description of problem:
I installed F6.91 on qemu (no GNOME, no X, no KDE, almost nothing) and updated 
it with yum. After that yum groupinstall "KDE (K Desktop Environment)" broke 
with "too many

Version-Release number of selected component (if applicable):
yum-3.1.4-1.fc7

How reproducible:
Always (tried three times).

Steps to Reproduce:
1. Install F6.91
2. yum -y update
3. yum -y groupinstall "KDE (K Desktop Environment"

Actual results:
yum breaks with:
error: cannot open Packages index using db3 - Too many open files (24)...
etc...
etc...

Additional info:
Look at the screenshot, qemu-0.9.0-2 (FC6), 1GB ram on the machine, 512MB for 
the virtual one + 8G virtual disk.

Comment 1 Doncho Gunchev 2007-03-09 20:57:49 UTC
Created attachment 149730 [details]
yum error while 'yum -y groupinstall "KDE (K Desktop Environment"'

Comment 2 Doncho Gunchev 2007-03-09 21:34:28 UTC
Looks like I was wrong about yum, it should be 
setroubleshoot-server-1.9.3-1.fc7. After the previous error I killed yum, 
rebuilt the rpm database (rpm --rebuilddb) and did 
a 'rpm -ihv /var/cache/yum/development/packages/*.rpm' - the same error. 
After 'service setroubleshoot stop; rpm --rebuilddb; setenforce 0' everything 
was fine (and just a bit faster).

Reassigning to setroubleshoot (I see no setroubleshoot-server), don't know 
about the Severity. Will attach screenshots.



Comment 3 Doncho Gunchev 2007-03-09 21:36:08 UTC
Created attachment 149744 [details]
setroubleshoot's error?

Comment 4 Doncho Gunchev 2007-03-09 21:38:36 UTC
Created attachment 149745 [details]
successfull rpm -ihv...

after stopping setroubleshoot and setenforce 0 (just for sure) rpm -ihv
--replacepkgs ... succeeded.


Note You need to log in before you can comment on or make changes to this bug.