Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231656 - NetLabel and IPsec management tools fail to start at boot
Summary: NetLabel and IPsec management tools fail to start at boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: RHEL5LSPPCertTracker
TreeView+ depends on / blocked
 
Reported: 2007-03-09 20:42 UTC by Paul Moore
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:38:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0544 normal SHIPPED_LIVE selinux-policy bug fix update 2007-11-08 14:16:49 UTC

Description Paul Moore 2007-03-09 20:42:25 UTC
Description of problem:
The NetLabel and IPsec management tools fail to start at boot due to problems 
with the MLS policy.  The IPsec problems have been discussed on the SELinux 
mailing list:

 * http://marc.theaimsgroup.com/?t=117346104800002&r=1&w=2
 * http://marc.theaimsgroup.com/?t=117346081500003&r=1&w=2

A series of patches have been posted to the SELinux mailing list which 
addresses these problems:

 * http://marc.theaimsgroup.com/?l=selinux&m=117347274928694&w=2

Version-Release number of selected component (if applicable):
selinux-policy-mls-2.4.6-30.el5

How reproducible:
Every time

Steps to Reproduce:
1. Configure NetLabel and/or IPsec to start at boot time
2. Boot the system
  
Actual results:
See the above mailing list links for detail

Expected results:
The system is configured as expected

Additional info:
This is directly related the LSPP certification efforts of Red Hat, HP, and 
IBM.

Comment 1 Daniel Walsh 2007-03-12 12:34:36 UTC
Patches applied to selinux-policy-2.4.6-45

Comment 2 Paul Moore 2007-03-12 14:47:12 UTC
I just tested selinux-policy-2.4.6-45 and can verify that it does solve the 
problems described in this bug report.

Comment 7 errata-xmlrpc 2007-11-07 16:38:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html



Note You need to log in before you can comment on or make changes to this bug.