Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231652 - migration: support conversion of bdb 4.2 files to bdb 4.3 and later
Summary: migration: support conversion of bdb 4.2 files to bdb 4.3 and later
Keywords:
Status: CLOSED DUPLICATE of bug 232050
Alias: None
Product: 389
Classification: Retired
Component: Database - General
Version: 1.0.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Orla Hegarty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 20:15 UTC by Rich Megginson
Modified: 2007-05-16 13:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 20:30:20 UTC


Attachments (Terms of Use)

Description Rich Megginson 2007-03-09 20:15:18 UTC
In order to support migration from ds 7.1 and 1.0.x to 1.1 (and 7.2), we need to
be able to support upgrading the bdb files created with 4.2 to 4.3 and later. 
Fedora only supports bdb 4.3 now, and will support 4.5 and 4.6 in the near
future.    During migration, we should be able to copy the database
files/directories to their new location (e.g. from
/opt/fedora-ds/slapd-instance/db to /var/lib/fedora-ds/slapd-instance/db) and
when the new server instance starts up, it should upgrade the new db files.

Comment 1 Noriko Hosoi 2007-03-20 20:30:20 UTC
I used the original bug 232050 "Change format of DBVERSION and guardian files"
for this issue.  (See the Comment #4 and #6)

*** This bug has been marked as a duplicate of 232050 ***


Note You need to log in before you can comment on or make changes to this bug.