Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231640 - Same two files included in two different packages
Summary: Same two files included in two different packages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeartwork
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 18:14 UTC by Hal Duston
Modified: 2007-12-06 20:13 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-06 18:46:49 UTC


Attachments (Terms of Use)

Description Hal Duston 2007-03-09 18:14:18 UTC
Description of problem:

/usr/share/icons/locolor/16x16/apps/ktimemon.png and
/usr/share/icons/locolor/32x32/apps/ktimemon.png are included in two packages.

Version-Release number of selected component (if applicable):
kdeaddons-3.5.6-0.3.fc6 and
kdeartwork-icons-3.5.6-0.1.fc6

How reproducible:
Always

Steps to Reproduce:
1. yum install kdeaddons
2. yum install kdeartwork-icons
3. rpmquery --list -v kdeaddons kdeartwork-icons | 
grep '/usr/share/icons/locolor/.*/apps/ktimemon.png' | sort
  
Actual results:
-rw-r--r--    1 root    root              306 Jan 19  
2006 /usr/share/icons/locolor/16x16/apps/ktimemon.png
-rw-r--r--    1 root    root              306 Sep 10  
2005 /usr/share/icons/locolor/16x16/apps/ktimemon.png
-rw-r--r--    1 root    root              345 Jan 19  
2006 /usr/share/icons/locolor/32x32/apps/ktimemon.png
-rw-r--r--    1 root    root              345 Sep 10  
2005 /usr/share/icons/locolor/32x32/apps/ktimemon.png

Expected results:
Only once occurrence of each file.

Additional info:

Comment 1 Rex Dieter 2007-12-06 18:46:49 UTC
1.  As long as the files don't conflict, strictly speaking, not a problem.

2.  It appears fixed in rawhide.

Comment 2 Hal Duston 2007-12-06 20:13:49 UTC
It's fixed in rawhide because kdeaddons has 
/usr/share/icons/locolor/16x16/apps/ktimemon.png and
/usr/share/icons/locolor/32x32/apps/ktimemon.png and kdeartwork-icons has
/usr/share/icons/Locolor/16x16/apps/ktimemon.png and
/usr/share/icons/Locolor/32x32/apps/ktimemon.png 
The files both have the same md5sum, but different timestamps, which caused 
rpmquery -v to always report that one of them as inconsistent with the RPMDB 
when they were had the same pathname.  Now they're stored in different 
directories, (by upper/lower case of /[Ll]ocolor/ only), so they no longer 
conflict, but the directory names differing only by upper/lower case raises a 
flag for me.


Note You need to log in before you can comment on or make changes to this bug.