Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231624 - system-config-soundcard doesn't play any sound
Summary: system-config-soundcard doesn't play any sound
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: sndconfig
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 16:11 UTC by Kelsang Tsenle
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 14:50:33 UTC


Attachments (Terms of Use)
one of the two log files (deleted)
2007-03-09 16:13 UTC, Kelsang Tsenle
no flags Details
the other log file (deleted)
2007-03-09 16:13 UTC, Kelsang Tsenle
no flags Details

Description Kelsang Tsenle 2007-03-09 16:11:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
The soundcard in this notebook is a 'Sigma Tel High Definition Audio CODEC, Location 65535'. (That's what Windows XP says, at least, I don't know another way to check. :) )

The audio configuration program (system-config-soundcard) recignizes this card as an ATI card, model 'SB450 HDA Audio' and tries to use the module 'snd-hda-intel'.

It doesn't play the test sound, though, and asks me to file a bug report here.

Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.3-2.fc6, alsa-lib-1.0.12-2.fc6, alsa-utils-1.0.12-3.fc6

How reproducible:
Always


Steps to Reproduce:
1. open system-config-soundcard
2. enter the root password
3. click on the 'play' button is 'Sound test'

Actual Results:
The 'Stopped' label is replaced by the 'Paying' label, but there isn't any sound. After a few seconds there's a window asking 'Did you hear the sample sound?'

Expected Results:
Roughly the same, but with sound.

Additional info:

Comment 1 Kelsang Tsenle 2007-03-09 16:13:24 UTC
Created attachment 149693 [details]
one of the two log files

Comment 2 Kelsang Tsenle 2007-03-09 16:13:56 UTC
Created attachment 149694 [details]
the other log file

Comment 3 Martin Stransky 2007-03-21 14:50:33 UTC
from dmesg:

...
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda_codec: invalid dep_range_val 0:7fff
hda_codec: invalid dep_range_val 0:7fff
...

hda-intel: Invalid position buffer, using LPIB read method instead.
...

Looks like a problem in drivers. Please report it to the ALSA Project
(www.alsa-project.org), they're authors of linux sound system.


Note You need to log in before you can comment on or make changes to this bug.