Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231621 - fix provided: basket-kontact
Summary: fix provided: basket-kontact
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: basket
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 15:42 UTC by Chitlesh GOORAH
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-12 10:01:06 UTC


Attachments (Terms of Use)

Description Chitlesh GOORAH 2007-03-09 15:42:57 UTC
Description of problem:
When basket-plugin is installed,
Every time I launched kontact, kontact crashes with:

WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.
WeaverThreadLogger: thread (ID: 1) suspended.
QDir::exists: Empty or null file name
QDir::exists: Empty or null file name
*** KMail got signal 11 (Crashing)
[anne@david ~]$ KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kontact path = <unknown> pid = 19533

'locate QDir' merely returns to the prompt.

Someone got the same problem on fedora-list
https://listman.redhat.com/archives/fedora-list/2007-February/msg02525.html

The solution to this problem is to ship the /usr/lib/libbasketcommon.la with the
package, if not every fedora user will encounter this packaging bug.


How reproducible:
Everytime

Steps to Reproduce:
1. yum install basket-kontact
2. kontact
3.
  
Actual results:
kontact crashes

Expected results:
kontact should launch successfully

Additional info:

Comment 1 Chitlesh GOORAH 2007-03-09 15:46:33 UTC
I've encountered this bug in both fc6 and -devel

(easy fix)

Comment 2 Rex Dieter 2007-03-09 16:21:33 UTC
I assume you verified that adding the .la file fixed the crasher?

AFAIK, there are other stability problems releated to basket-kontact, but 
that's mostly just hear-say, which all originates with this bug.

Comment 3 Chitlesh GOORAH 2007-03-09 16:33:09 UTC
(In reply to comment #2)
> I assume you verified that adding the .la file fixed the crasher?
> 

Yes I did.

Comment 4 Rex Dieter 2007-03-09 16:40:31 UTC
Re: comment #2
make that "... which *may* all originate with this bug".

Comment 5 Aurelien Bompard 2007-03-10 07:50:06 UTC
Strange, I can't reproduce it. Kontact starts just fine with the basket plugin
here, and I have no libbasketcommon.la file.
I've added it to the package however, please tell me if those work for you :
http://gauret.free.fr/fichiers/rpms/fedora/temp/basket-1.0-3.fc6.i386.rpm
http://gauret.free.fr/fichiers/rpms/fedora/temp/basket-kontact-1.0-3.fc6.i386.rpm

Comment 6 Chitlesh GOORAH 2007-03-11 14:34:20 UTC
It is quite strange as well.
Adding the libbasketcommon.la doesn't fix it at all.

I have 2 users on the same machine and thus the same version of basket-kontact.
However with the (virgin) user kontact crashes each time with the
basket-kontact, but not the (old) user, I use everyday. I think it has something
to do with personal settings on kontact.

Comment 7 Chitlesh GOORAH 2007-06-12 10:01:06 UTC
I'm closing this bug. I'm no logner having this issue anymore.


Note You need to log in before you can comment on or make changes to this bug.