Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231603 - Gnome-terminal crashes during startup on compiz/beryl
Summary: Gnome-terminal crashes during startup on compiz/beryl
Keywords:
Status: CLOSED DUPLICATE of bug 231454
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 13:42 UTC by Mohd Izhar Firdaus Ismail
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 23:44:16 UTC


Attachments (Terms of Use)

Description Mohd Izhar Firdaus Ismail 2007-03-09 13:42:22 UTC
Description of problem:
Gnome-terminal crashes with X Window System invalid parameter attributes error 

launching it from xterm gives this output

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1093 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Version-Release number of selected component (if applicable):
gnome-terminal-2.17.92-1.fc7

How reproducible:
very frequently

Steps to Reproduce:
1. run compiz/beryl
2. start gnome-terminal
  
Actual results:
crashes

Expected results:
run

Additional info:

Comment 1 David Nielsen 2007-03-11 01:28:08 UTC
I'm seeing the same on x86_64, there's no stack available when you run it
through gdb so I can't provide additional information to help track it down.

there's a lot of errors like so:

(gnome-terminal:7433): Vte-WARNING **: Can not find appropiate font for characte
r U+ac10.

If you repeatedly attempt to start up gnome-terminal from the menu it will
eventually start but exit without starting bug-buddy at rather random intervals.

Comment 2 Peter Gordon 2007-03-12 05:23:11 UTC
A "me too" here.

This didn't seem to happen when I played with Compiz last week. Was there
anything significant between then and now in gnome-terminal or Compiz that may
be causing this?

Thanks.

Comment 3 Scott Talbot 2007-03-12 14:19:19 UTC
Add to this a (possible) related that windows (not all of them, but most) open
with the title (drag) bar off-screen.  Once dragged below the panel they can't
be moved above it.  (Not checked with beryl, but if compiz is enabled this happens.)

Comment 4 Behdad Esfahbod 2007-03-12 23:44:16 UTC

*** This bug has been marked as a duplicate of 231454 ***


Note You need to log in before you can comment on or make changes to this bug.