Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231602 - crash on start
Summary: crash on start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glipper
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Damien Durand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 13:35 UTC by Matěj Cepl
Modified: 2018-04-11 17:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-13 15:45:05 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2007-03-09 13:35:00 UTC
Description of problem:
glipper doesn't start at all. Immediately crashes with this backtrace:

(gdb) thread apply all bt

Thread 1 (Thread 46912496323600 (LWP 7325)):
#0  0x0000003d68076d40 in memcpy () from /lib64/libc.so.6
#1  0x0000003d6805fa23 in _IO_getline_info_internal () from /lib64/libc.so.6
#2  0x0000003d6805e999 in fgets () from /lib64/libc.so.6
#3  0x0000000000403f38 in readPreferences () at /usr/include/bits/stdio2.h:109
#4  0x0000000000404f81 in main (argc=1, argv=0x7fff969872a8) at main.c:608
#5  0x0000003d6801d8a4 in __libc_start_main () from /lib64/libc.so.6
#6  0x0000000000403bc9 in _start ()

Version-Release number of selected component (if applicable):
glipper-0.95.1-2.fc6

How reproducible:
100%

Steps to Reproduce:
1. run glipper
2.
3.
  
Actual results:
crashes

Expected results:
shouldn't

Additional info:

Comment 1 Matěj Cepl 2007-03-09 13:35:54 UTC
Sorry, one more data point -- I am using glipper on RHEL5-Gold with this kernel

Linux hubmaier 2.6.18-8.el5xen #1 SMP Fri Jan 26 14:29:35 EST 2007 x86_64 x86_64
x86_64 GNU/Linux


Comment 2 Matěj Cepl 2007-05-16 13:52:15 UTC
I can even bt full backtrace if you want :-)

(gdb) bt full
#0  0x0000003ec9476ed0 in memcpy () from /lib64/libc.so.6
No symbol table info available.
#1  0x0000003ec945fbb3 in _IO_getline_info_internal () from /lib64/libc.so.6
No symbol table info available.
#2  0x0000003ec945eb29 in fgets () from /lib64/libc.so.6
No symbol table info available.
#3  0x0000000000403f38 in readPreferences () at /usr/include/bits/stdio2.h:109
        len = 8247290742599319564
        path = <value optimized out>
        prefFile = (FILE *) 0x645b80
#4  0x0000000000404f81 in main (argc=1, argv=0x7fffed407b38) at main.c:608
No locals.
#5  0x0000003ec941da44 in __libc_start_main () from /lib64/libc.so.6
No symbol table info available.
#6  0x0000000000403bc9 in _start ()
No symbol table info available.
(gdb) 



Comment 3 Damien Durand 2007-06-13 15:45:05 UTC
Hi, thank you for your report but glipper is not built for rhel. You can rebuilt
SRPM file and try to install it but it's at your risk. I close this report as
not a bug.


Note You need to log in before you can comment on or make changes to this bug.