Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231599 - MH-E doesn't complete threading a folder
Summary: MH-E doesn't complete threading a folder
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs-packages-extra
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 12:27 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-01 15:52:03 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2007-03-09 12:27:09 UTC
Description of problem:
In an MH-E folder buffer, pressing "T t" (to thread it) just gives 'End of file
or stream: "internal input stream"', the folder isn't threaded

Version-Release number of selected component (if applicable):
xemacs-packages-extra-el-20060510-4.fc6

How reproducible:
Always

Steps to Reproduce:
1. M-x mh-rmail
2. Tt
3.
  
Actual results:
End of file or stream: "internal input stream"

Expected results:
Threaded folder

Additional info
xemacs-21.5.27-8.fc7, it used to work with the version before this one.

Comment 1 Ville Skyttä 2007-03-11 15:44:38 UTC
(In reply to comment #0)
> xemacs-21.5.27-8.fc7, it used to work with the version before this one.

Hm, previous version of xemacs or xemacs-packages-extra?  Which are the exact
versions of xemacs and xemacs-packages-extra it worked with?

Comment 2 Horst H. von Brand 2007-03-11 15:59:34 UTC
xemacs, xemacs-packages-extra hasn't changed in ages (it is still .fc6).
xemacs-packages-{base,extra} are from Sep 10, 2006, installed the next day.

I dunno which version of xemacs was before, the rotation of yum.log erased the
record of that one's installation.

Comment 3 Ville Skyttä 2007-03-11 17:05:39 UTC
The only changes between xemacs 21.5.27-7.fc7 and 8.fc7 were these:

http://cvs.fedora.redhat.com/viewcvs/devel/xemacs/xemacs-21.5.27-canna-222559.patch?root=extras&rev=1.1&view=auto
http://cvs.fedora.redhat.com/viewcvs/devel/xemacs/xemacs-sitestart.el?root=extras&r1=1.6&r2=1.7

Both look innocent enough to me, but perhaps you could test if reverting the
site-start.el change has any effect.  What's your $LANG environment variable set to?

Comment 4 Horst H. von Brand 2007-03-15 15:31:03 UTC
LANG=en_US.UTF-8

In any case, this went away (by mistake I tried reading email in xemacs, and it
worked this time, after reliably *not* working starting last week). Sorry, I
can't point at any of the many updates to rawhide which fixed this.

I guess you can close it now... sorry for the time wasted.

Thanks!

Comment 5 Horst H. von Brand 2007-03-18 00:22:47 UTC
Sorry, false alarm. When threading a huge folder (a few thousand messages,
message numbers up in the 80 thousands) it hung again. The workaround was to
thread the folder in plain emacs, delete a few hundred messages (junk easily
sorted by Subject:) and get at it again in xemacs.

Comment 6 Horst H. von Brand 2007-07-17 13:27:07 UTC
Futzing around with GNU emacs, it seems that when deleting a large number of
messages (or large messages) it runs out of "undo" space (that is the message
GNU emacs gives, instead of just hanging).

Why does it save the deleted messages in undo? MH saves them as ",<msg>" in the
folder, so they aren't lost. I suspect this is what makes many MH-E operations slow.

Comment 7 Horst H. von Brand 2007-10-01 13:29:07 UTC
After not using xemacs for quite some time for email, I tried again. I now seems
to work (xemacs-21.5.28-5.fc8, xemacs-packages-extra-20070427-1.fc8,
nmh-1.2-20070115cvs.4.fc8).

Comment 8 Ville Skyttä 2007-10-01 15:52:03 UTC
Thanks for the feedback, assuming fixed.


Note You need to log in before you can comment on or make changes to this bug.