Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231593 - Puplet (Pirut) only updates once
Summary: Puplet (Pirut) only updates once
Keywords:
Status: CLOSED DUPLICATE of bug 228994
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 06:58 UTC by Patrick Steiner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 20:54:52 UTC


Attachments (Terms of Use)

Description Patrick Steiner 2007-03-09 06:58:46 UTC
Description of problem:
If i start puplet it automatically notifies updates, but this only works once, i
have to restart the application (or restart my machine) to get a new
notification. but the applications always runs i the background. is this normal?

btw. i know i can do a yum update but a visual notification would be nicer.

Version-Release number of selected component (if applicable):


How reproducible:
start puplet make a update an wait.... :-) nothing will be done anymore


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-03-19 21:55:18 UTC
This should work fine; it does for me.  Can you try running yum-updatesd in the
foreground of a terminal (yum-updatesd -f) and then puplet in another and see if
there are any errors reported?

Comment 2 Patrick Steiner 2007-03-22 06:36:55 UTC
i have testet the command yum-updatesd -f now on 2 different machines (one was
fresh installed yesterday).
on the fresh installed machine i get no output. on the second one yum-updatesd
now  only outputs:

yum-updatesd -f
Loading "installonlyn" plugin

now for over a day :-)

Comment 3 Patrick Steiner 2007-03-28 06:15:51 UTC
i think i found the problem. shouldn't yum-updatesd send dbus messages? if i run
dbus-monitor i cant see any message, but in /etc/yum/yum-updatesd.conf 
emit_via = dbus is set.

Comment 4 Patrick Steiner 2007-03-28 06:25:30 UTC
no dbus seams to work!

if i test with this python script:

#!/usr/bin/python
import dbus
bus = dbus.SystemBus()
obj = bus.get_object("edu.duke.linux.yum", "/Updatesd")
res = obj.GetUpdateInfo(dbus_interface="edu.duke.linux.yum")
print res

i get some infos back.

Comment 5 Patrick Steiner 2007-03-28 07:03:30 UTC
it think this has something to do with this bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=228994

Comment 6 Patrick Steiner 2007-03-28 09:23:32 UTC
i looked into /usr/bin/puplet

shouldnt the function _refreshInfo called every 10 mins?

i have added a simple print command into this function but this is only called once.

Comment 7 Jeremy Katz 2007-04-09 20:54:52 UTC

*** This bug has been marked as a duplicate of 228994 ***


Note You need to log in before you can comment on or make changes to this bug.