Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231591 - gcc-java dependent on eclipse-ecj via /usr/share/java/eclipse-ecj.jar
Summary: gcc-java dependent on eclipse-ecj via /usr/share/java/eclipse-ecj.jar
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 06:37 UTC by Paul Dickson
Modified: 2014-01-21 22:57 UTC (History)
5 users (show)

Fixed In Version: 3.2.8-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-12 13:59:05 UTC


Attachments (Terms of Use)

Description Paul Dickson 2007-03-09 06:37:54 UTC
Description of problem:
yum would not update gcc-java due to the lack of the file:
/usr/share/java/eclipse-ecj.jar

I had to install eclipse-ecj before gcc-java and gcc would update.

Version-Release number of selected component (if applicable):
gcc-java-4.1.2-3

How reproducible:
Always

Steps to Reproduce:
1. uninstall eclipse-ecj
2. update gcc (and gcc-java)
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2007-03-11 16:14:35 UTC
It is completely intentional that gcc-java now depends on eclipse-ecj.jar.


Comment 2 Paul Dickson 2007-03-12 04:17:09 UTC
My point is that yum wasn't pulling in eclipse-ecj.jar.  gcc was failing to
updated because of a dependency on /usr/share/java/eclipse-ecj.jar.

Comment 3 Pekka Savola 2007-09-18 05:42:52 UTC
I've hit this recently on Fedora 7 install, and F7 updates have stalled for
about two weeks because this dependency isn't satisfied properly in yum.

One potential source of problem may have been that it seems I had an old version
of eclipse-ecj rpm (3.2.2-14.fc7) sitting on /var/cache/yum/fedora/packages
directory for some reason (maybe from an older update attempt).  I wonder if
that was messing up the update for some reason.  After manually installing it
and rerunning yum update, the first thing yum did was download eclipse-ecj
3.2.2-15.fc7.

I think this is a problem so re-opening.

Comment 4 Jeremy Katz 2007-09-18 18:17:26 UTC
What version of yum do you have installed?

Comment 5 Pekka Savola 2007-09-19 04:50:34 UTC
It's impossible to say for sure because yum was upgraded in the same ago, but if
I'd have to guess, I'd say it was 3.2.2 because I recall that was the
next-to-latest yum update that was pushed to updates/updates-testing.

Comment 6 Seth Vidal 2008-03-12 13:59:05 UTC
okay - this was most likely a file lookup problem in 3.2.2. I've recently tested
non-primary-file-dep look ups and found them working properly. If you find a
problem in yum 3.2.8 or above please file a new bug.

Thanks


Note You need to log in before you can comment on or make changes to this bug.