Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231574 - dvdisaster is intentionally crippled
Summary: dvdisaster is intentionally crippled
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dvdisaster
Version: rawhide
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-09 03:17 UTC by Philippe Troin
Modified: 2013-03-15 11:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-15 11:52:13 UTC


Attachments (Terms of Use)
patch for the spec file, and patch file for dvdisaster 0.72.4 (deleted)
2013-03-09 09:21 UTC, Paolo Bonzini
no flags Details | Diff

Description Philippe Troin 2007-03-09 03:17:42 UTC
In scsi-layer.c, function OpenAndQueryDevice, at line 1183:

   if(dh->mainType == DVD && query_copyright(dh))
   {  CloseDevice(dh);
      Stop(_("This software does not support encrypted media.\n"));
   }

Any chance this code would be commented out with a patch?

Comment 1 Carsten Gnoerlich 2007-03-09 20:49:15 UTC
That code is simply a graceful stop for CSS-encryted
media. Removing it won't enable you to read such media,
as the program has no capabilities for decrypting CSS.
You would simply get throusands of error messages 
when trying to read the encrypted sectors later.

Comment 2 Dmitry Butskoy 2007-03-12 11:59:37 UTC
> the program has no capabilities for decrypting CSS

Is it possible to check at runtime whether libdvdcss is installed in the system,
and dynamically load it then? Or maybe provide some just an external module for
decrypt functionality (external due to patent/etc. issues)?
Just thoughts... :)

Comment 3 Carsten Gnoerlich 2007-03-12 20:44:41 UTC
Hi Dmitry and Phil,

libdvdcss support wouldn't fit well into the dvdisaster framework.

Technically, dvdisaster follows the "One tool, one purpose" discipline. 
It is heavily optimized towards protecting and recovering data 
on (re-)writeable media. 
Decrypting DVD-ROM is a completely different story. It would coerce 
dvdisaster into something it was not designed for. 

Practically, circumventing CSS leads to legal encumberance in many 
countries. Some may ban development and distribution of the program.
That should not be taken lightly. The data protection and recovery
capabilities of dvdisaster are unique. It is not easily replaceable
with other software. Is it worth legally tainting it?

Just some thoughts from the maintainer's perspective.

  Carsten 

Comment 4 Paolo Bonzini 2013-03-09 09:19:42 UTC
Reopening.  The program has no capabilities for decrypting CSS, but one does not need to decrypt CSS when reparing a DVD that you have legally bought in your region.  Even for encrypted media, it is usually enough to first "unlock" the DVD by opening it in totem or vlc.  After that, dvdisaster can successfully read the image.

Regarding the tainting of dvdisaster, Debian is already shipping a similar patch, so we would not change anything.

Comment 5 Paolo Bonzini 2013-03-09 09:21:24 UTC
Created attachment 707351 [details]
patch for the spec file, and patch file for dvdisaster 0.72.4

Comment 6 Dmitry Butskoy 2013-03-15 11:52:13 UTC
I had now discussion with the upstream developer.

The problem is in his country's local laws (seems Germany).

In short:
- it is forbidden to publish a software which can be used to circumvent copy protection;
- to follow this, most dvd-related applications just stop read on the first unreadable (say encrypted) sector;
- but dvdisaster obviously cannot follow this scheme, since it is a recovery tool;
- the only way found is to drop any "pressed DVD media" (eg. DVD-ROM).

It might looks some strange, but very often copy protection laws have ambiguous interpretation...

Besides this, I doubt whether the proposed feature is actually useful for most users. IMHO Dvdisaster is mostly targeted for (user) writeable dvd media, rather than some bought dvd-roms.

IOW, if somebody want to distribute a "patched" version of dvdisaster, he/she should use repositories like Livna .


Sorry, closed wantfix. :(


Note You need to log in before you can comment on or make changes to this bug.