Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231560 - checkdbs script run by cron fails with error
Summary: checkdbs script run by cron fails with error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mailman
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 23:13 UTC by Magnus Morén
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-15 08:41:07 UTC


Attachments (Terms of Use)

Description Magnus Morén 2007-03-08 23:13:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20061023 SUSE/2.0.0.1-0.1 Firefox/2.0.0.2pre

Description of problem:
The file /etc/cron.d/mailman has this cron job entry:
  0 8 * * * mailman /usr/lib/mailman/cron/checkdbs


This script produces the following error (and mail the output to mailman@my.list.server) every morning:


Traceback (most recent call last):
  File "/usr/lib/mailman/cron/checkdbs", line 178, in ?
    main()
  File "/usr/lib/mailman/cron/checkdbs", line 109, in main
    text += '\n' + pending_requests(mlist)
  File "/usr/lib/mailman/cron/checkdbs", line 128, in pending_requests
    for id in mlist.GetSubscriptionIds():
  File "/usr/lib/mailman/Mailman/ListAdmin.py", line 140, in GetSubscriptionIds
    return self.__getmsgids(SUBSCRIPTION)
  File "/usr/lib/mailman/Mailman/ListAdmin.py", line 132, in __getmsgids
    ids = [k for k, (op, data) in self.__db.items() if op == rtype]
ValueError: unpack tuple of wrong size


Version-Release number of selected component (if applicable):
mailman-2.1.5.1-34.rhel4.5

How reproducible:
Always


Steps to Reproduce:
1. Install and configure mailman
2. Wait for cron to run the script

or 

3. su mailman -c /usr/lib/mailman/cron/checkdbs

Actual Results:
Error code as described above

Expected Results:
No error code

Additional info:
The maillist server are in others parts working fine and serves about 200 mailing lists

Comment 1 Tomas Smetana 2007-04-27 12:48:48 UTC
This seems to be the same as the following:
http://mail.python.org/pipermail/mailman-users/2007-April/056485.html


Comment 2 Magnus Morén 2007-04-27 14:26:48 UTC
Thanks!

The method described in this article helped me to find a corrupt request.pck in
*one* of the lists on this server.

/usr/lib/mailman/bin/dumpdb ./request.pck on that file showed a lot of data but
I could not see anything strange (and if I had, I have no clue on how to fix this).

My solution was to remove the file. It is recreated when you "Tend to pending
moderator requests" in the web front-end.

Comment 3 RHEL Product and Program Management 2007-05-09 05:48:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 RHEL Product and Program Management 2007-05-15 08:41:07 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.