Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231558 - message from /etc/init.d/network
Summary: message from /etc/init.d/network
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 22:53 UTC by Ulrich Drepper
Modified: 2014-03-17 03:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 02:21:48 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2007-03-08 22:53:51 UTC
Description of problem:
The network script says I should re-run itself:

~$ service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
SIOCGIFFLAGS: No such device
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... done.
Global IPv6 forwarding is enabled in configuration, but not currently enabled in
kernel
Please restart network with '/sbin/service network restart'
                                                           [  OK  ]


That's of course bogus here since I just ran the script and it causes this message.


Version-Release number of selected component (if applicable):
initscripts-8.45.7-1

How reproducible:
always

Steps to Reproduce:
1.I added IPV6INIT=yes to an ifcfg-ethX file
2.run service network restart
3.
  
Actual results:
see message above

Expected results:
better message

Additional info:

Comment 1 Bill Nottingham 2007-03-09 02:55:23 UTC
Can you attach your full ifcfg file, and /etc/sysctl.conf?

Comment 2 Ulrich Drepper 2007-03-14 14:33:59 UTC
Nothing changed in the sysctl.conf file, standard as it comes with the system.

This is the ifcfg-eth0 file

DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=xx:xx:xx:xx:xx:xx
IPV6INIT=yes
IPV6FORWARDING=yes

This is /etc/sysconfig/network:

NETWORKING=yes
HOSTNAME=localhost.localdomain
NETWORKING_IPV6=yes


Comment 3 Bill Nottingham 2007-04-17 02:21:48 UTC
Ugh, those ipv6 scripts are fun. After enough digging:

IPV6INIT and IPV6FORWARDING are global parameters - they can't be set
per-interface. That's what's causing the weird errors you see - if you set them
in /etc/sysconfig/network, it should behave.


Note You need to log in before you can comment on or make changes to this bug.