Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231494 - Anaconda crashes during scan for existing Fedora systems
Summary: Anaconda crashes during scan for existing Fedora systems
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 18:27 UTC by Bruno Wolff III
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-14 14:19:22 UTC


Attachments (Terms of Use)
Anaconda dump file (deleted)
2007-03-08 18:27 UTC, Bruno Wolff III
no flags Details
Anaconda traceback (deleted)
2007-03-31 22:54 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2007-03-08 18:27:19 UTC
Description of problem:
When attempting to do an install, today's and yesterday's boot.iso versions
crash when scanning for existing systems.


Version-Release number of selected component (if applicable):
11.2.0.31-1

How reproducible:
100% on my system.

Steps to Reproduce:
1. Try to do an install with today's boot.iso file.
  
Actual results:
Anaconda crashes

Expected results:
Anaconda detects existing Fedora installations.

Additional info:
Due to another problem neither of my hard drives are visible so there are zero
disk partitions to search. This may or may not have any bearing on the above.

I also tried using the updates feature to use update *.py files from cvs, but
saw the same problem.

Comment 1 Bruno Wolff III 2007-03-08 18:27:20 UTC
Created attachment 149601 [details]
Anaconda dump file

Comment 2 Bruno Wolff III 2007-03-14 03:29:45 UTC
I retested this using a boot.iso version from early March 13th and the problem
is still happening.

Comment 3 Chris Lumens 2007-03-14 18:35:45 UTC
What kind of hard drives, controller, etc. are you using?

Comment 4 Bruno Wolff III 2007-03-14 19:34:10 UTC
You can look at 227281 to see that saga. This ticket wasn't about getting
anaconda to see the drives, but rather about the failure more.
The controller that has the drives attached is the highpoint 302. It has 2 PATA
WD Caviars attached. (The motherboard has two sets of controllers. The AMD one
has DVD drives attached, and nothing is connected to the promise controller.)
When the problem with the drives not showing up first started happening, I
didn't get tracebacks from anaconda. It just showed an empty list of available
disk drives. Something changed recently with that.

Comment 5 Jeremy Katz 2007-03-23 18:13:43 UTC
This should be fixed with the booty that I built this afternoon and which will
be in test3

Comment 6 Bruno Wolff III 2007-03-31 22:54:33 UTC
Created attachment 151368 [details]
Anaconda traceback

I just retested this with the Friday (March 30) morning boot.iso and it seems
to still be happening.
However, kudzu changed and my disk drives became visible again, so I had to
change the way I tested this. When I got to the screen after the media check I
switched to tty2 and unloaded the disk controller driver and then continued the
install from X. I then saw a crash at the same point I had previously.
I am attaching the saved traceback.

Comment 7 Bruno Wolff III 2007-04-14 14:19:22 UTC
I retested this with a snapshot from Friday April 13 and things now work as
expected.


Note You need to log in before you can comment on or make changes to this bug.