Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231459 - Right click/Eject on CDROM from gnome desktop fails to eject
Summary: Right click/Eject on CDROM from gnome desktop fails to eject
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 15:17 UTC by Tom London
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 14:40:35 UTC


Attachments (Terms of Use)

Description Tom London 2007-03-08 15:17:59 UTC
Description of problem:
Right clicking and selecting 'Eject' on cdrom on gnome desktop unmounts the cd,
but fails to eject.  An error popup appears.....

(Running SELinux targeted/enforcing)

The following appears in /var/log/messages:


Mar  8 06:58:09 localhost setroubleshoot:      SELinux is preventing
/usr/sbin/userhelper (hald_t) "write" to eject (etc_t).      For complete
SELinux messages. run sealert -l 0fa5c1a3-cca3-49cd-8608-7a7b5a545312
Mar  8 06:58:09 localhost setroubleshoot:      SELinux is preventing
/usr/sbin/userhelper (hald_t) "setexec" access to <Unknown> (hald_t).      For
complete SELinux messages. run sealert -l aa87c6fa-6163-4a1b-a62f-38e657c87d6f

complete AVC:

type=AVC msg=audit(1173365886.796:29): avc:  denied  { setexec } for  pid=4044
comm="userhelper" scontext=system_u:system_r:hald_t:s0
tcontext=system_u:system_r:hald_t:s0 tclass=processtype=SYSCALL
msg=audit(1173365886.796:29): arch=40000003 syscall=4 success=no exit=-13 a0=4
a1=8dcea48 a2=1c a3=43469be9 items=0 ppid=4043 pid=4044 auid=4294967295 uid=0
gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) comm="userhelper"
exe="/usr/sbin/userhelper" subj=system_u:system_r:hald_t:s0 key=(null)

Version-Release number of selected component (if applicable):
usermode-1.87-3

How reproducible:
Every time

Steps to Reproduce:
1. right click on cdrom icon on gnome desktop
2. select 'eject'
3.
  
Actual results:
CD is unmounted, error popup, eject fails.

Expected results:


Additional info:

Comment 1 Daniel Walsh 2007-03-09 14:07:45 UTC
The problem is the hal patch to use /usr/sbin/eject instead of /usr/bin/eject
was dropped, in the devel branch.  Please read the patch.


Note You need to log in before you can comment on or make changes to this bug.