Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231443 - Extras' irssi seems to have no scripting support
Summary: Extras' irssi seems to have no scripting support
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: irssi
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 12:12 UTC by Vittorio Sozzi
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-08 17:45:33 UTC


Attachments (Terms of Use)

Description Vittorio Sozzi 2007-03-08 12:12:38 UTC
Description of problem: Extras' irssi seems to have no scriptin support

When trying to load a script using the /script command the output is the following:

Irssi: Unknown command: script

Version-Release number of selected component (if applicable):irssi-0.8.10-6.a.fc6

How reproducible: always


Steps to Reproduce:
1. Try the /script command

  
Actual results:
Irssi: Unknown command: script

Expected results:
Should be loading the script

Comment 1 Robert Scheck 2007-03-08 13:58:49 UTC
There IS scripting support. A simple "echo 'load perl' >> $HOME/.irssi/startup" 
will do what you're expecting at the next irssi startup.

Comment 2 Robert Scheck 2007-03-08 14:01:18 UTC
Please mark this bugreport as DUPLICATE of bugzilla ID #143696 - thanks. 
NOTABUG, just a feature ;-)

Comment 3 Vittorio Sozzi 2007-03-08 14:04:01 UTC
Whoops... sorry :)

Comment 4 Dams 2007-03-08 17:45:33 UTC
Definitely not a bug. perl support is modular and can be loaded with a "/load
perl" and default-loaded with the way Robert described.



Note You need to log in before you can comment on or make changes to this bug.