Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231433 - audacious doesn't start
Summary: audacious doesn't start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-08 09:06 UTC by Thorsten Leemhuis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-06 21:47:24 UTC


Attachments (Terms of Use)

Description Thorsten Leemhuis 2007-03-08 09:06:23 UTC
Description of problem:
audacious doesn't start on a up2date rawhide machine:

$ audacious 
GTK Accessibility Module initialized
[nothing]

Doing this works:
$ ssh localhost audacious 

The root of the problem is probably the same as discussed in Bug 227828 Comment
#10 and later.

Comment 1 Thorsten Leemhuis 2007-03-08 13:20:54 UTC
FYI, disabling accessibility features with gnome-at-properties works around the
problem

Comment 2 Ralf Ertzinger 2007-03-08 14:52:34 UTC
Reproduced.

Comment 3 Ralf Ertzinger 2007-03-09 13:47:01 UTC
Hrm. audacious makes generous use of GDK_THREADS_ENTER and GDK_THREADS_LEAVE. My
attempts at fixing this have just produced lockups sooner or later.

Stay tuned.

Comment 4 Ralf Ertzinger 2007-03-15 13:11:44 UTC
Upstream has released 1.3.1, which seems to fix this problem.
However, it requires a new library (mcs), which is not in FE yet.

I have built a package and requested it for review, Bug 232342.

Comment 5 Ralf Ertzinger 2007-04-06 21:47:24 UTC
Fixed in the 1.3.1 releases 


Note You need to log in before you can comment on or make changes to this bug.