Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231338 - internal compiler error: in dwarf2out_finish
Summary: internal compiler error: in dwarf2out_finish
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 19:41 UTC by Mike Lindner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.1.1-1.fc5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 14:48:03 UTC


Attachments (Terms of Use)
Preprocessed source to exhibit bug (deleted)
2007-03-07 19:42 UTC, Mike Lindner
no flags Details

Description Mike Lindner 2007-03-07 19:41:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
Compiler crash

gcc -o Linux_All_DBG.OBJ/jscpucfg.o -c -Wall -Wno-format -DGCC_OPT_BUG -g -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R -DX86_LINUX  -DDEBUG -DDEBUG_mikel -DEDITLINE -ILinux_All_DBG.OBJ  jscpucfg.c
jscpucfg.c:374: internal compiler error: in dwarf2out_finish, at dwarf2out.c:14116
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cckS5JIa.out file, please attach this to your bugreport.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Trying to compile spidermonkey 1.60
2.Will attach file

Actual Results:


Expected Results:


Additional info:

Comment 1 Mike Lindner 2007-03-07 19:42:12 UTC
Created attachment 149482 [details]
Preprocessed source to exhibit bug

Comment 2 Jakub Jelinek 2007-03-12 14:48:03 UTC
Can't reproduce with current FC5 gcc (4.1.1-51.fc5), nor with an earlier
FC5 update gcc (4.1.1-1.fc5).


Note You need to log in before you can comment on or make changes to this bug.