Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231272 - Tomboy refuses to start because per-user inotify watches limit of 8192 has been reached
Summary: Tomboy refuses to start because per-user inotify watches limit of 8192 has b...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: tomboy
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 08:49 UTC by Colin Charles
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-18 18:41:02 UTC


Attachments (Terms of Use)

Description Colin Charles 2007-03-07 08:49:28 UTC
Description of problem: Try to start tomboy, and watch it fail


Version-Release number of selected component (if applicable):
tomboy-0.4.1-1.fc6.x86_64.rpm

How reproducible:
100% when it happens

Steps to Reproduce:
1. Try to launch Tomboy
2. Notice the error message

Note this only happens "occasionally". I don't think this is a tomboy fault,
more an inotify fault. What's taking up all the inotify watches? Or how do I tell?
  
Actual results:
tomboy
NoteManager created with note path "/home/byte/.tomboy".

Unhandled Exception: System.ComponentModel.Win32Exception: The per-user inotify
watches limit of 8192 has been reached. If you're experiencing problems with
your application, increase that limit in /proc/sys/fs/inotify/max_user_watches.
  at System.IO.InotifyWatcher.StartMonitoringDirectory (System.IO.InotifyData
data, Boolean justcreated) [0x00000] 
  at System.IO.InotifyWatcher.StartDispatching (System.IO.FileSystemWatcher fsw)
[0x00000] 
  at System.IO.FileSystemWatcher.Start () [0x00000] 
  at System.IO.FileSystemWatcher.set_EnableRaisingEvents (Boolean value) [0x00000] 
  at (wrapper remoting-invoke-with-check)
System.IO.FileSystemWatcher:set_EnableRaisingEvents (bool)
  at Tomboy.PluginManager..ctor (System.String plugins_dir) [0x00000] 
  at Tomboy.NoteManager.CreatePluginManager () [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory, System.String
backup_directory) [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000] 
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] 


Expected results:
Tomboy starts

Additional info:
Is there a way to tell whats eating up all the inotify watches? Running
inotifywatch also, doesn't help since all the watches are used up. Is 8192 too
small?

This is a fresh FC-6 installation.

Feel free to reassign to kernel if its more appropriate there...

Comment 1 Ray Strode [halfline] 2008-03-18 18:41:02 UTC
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.