Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231269 - Kernel panic during DHCP, Realtek RTL8168/8111 in NB Asus A67
Summary: Kernel panic during DHCP, Realtek RTL8168/8111 in NB Asus A67
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 06:50 UTC by Tomas Prochazka
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-23 17:25:35 UTC


Attachments (Terms of Use)
Cumulative r8169.c patch (deleted)
2007-04-01 23:38 UTC, Jost Diederichs
no flags Details | Diff

Description Tomas Prochazka 2007-03-07 06:50:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Description of problem:
When Fedora try connect to Internet via DHCP, fedora freeze, only keyborad blinking (kernel panic). When I put off ethernet kable, fedora start correctly. When I put in cable after it and try activate eth0, fedora freeze.

I have Notebook ASUS A6T, which has Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC.

I can send some log.

Version-Release number of selected component (if applicable):
tested in kernel-2.6.20-1.2966.fc7.x86_64.rpm and kernel-2.6.20-1.2949.fc7.x86_64.rpm

How reproducible:
Always


Steps to Reproduce:
1. Only install and run Fedora Core Test 2 on Asus A6T Notebook with Realtek RTL8168/8111 ethernet card.


Actual Results:


Expected Results:


Additional info:

Comment 1 Vaclav "sHINOBI" Misek 2007-03-07 13:10:35 UTC
I have the similar problem (same test release and kernel versions). My HW is
also x86_64 Realtek RTL8168/8111 (both cards on motherboard), motherboard MSI
K9A Platinum. r8168 module is loaded without problems, but it crashes during
network startup. I'm using fixed IP addresses and with this setting kernel
crashes everytime when this network controller is set to ONBOOT=yes.
I'm booting the kernel with pci=nomsi option (as the SATA controller is
unavailable without this).


Comment 2 Jost Diederichs 2007-03-23 14:57:27 UTC
I appear to have the same issue. r8169.ko module appears to load but kernel
panic on ifup. 
mad64 system with nvidia chipset. r8169 controller on PCI card.
kernel-2.6.20-1.3003.fc7.x86_64

Comment 3 Jost Diederichs 2007-03-26 00:47:07 UTC
With kernel 2.6.20-1.3017.fc7.x86_64 the problem has disappeared. 
According to the kernel changelog, no_hz was disabled, and may be that mitigated
the problem. 

Comment 4 Vaclav "sHINOBI" Misek 2007-03-26 10:35:44 UTC
On my system the problem still persists even with 2.6.20-1.3017.fc7.x86_64. With
the latest kernels it's possible to ifup interface without oops, but ONLY
without network cable plugged to the interface. With the cable it oopses every time.

Comment 5 Jost Diederichs 2007-03-28 06:06:16 UTC
Correction,
that the problem was fixed with kernel 2.6.20-1.3017.fc7.x86_64 was an
overstatement - the kernel still oopses once a day. 
Now with kernel 2.6.20-1.3023.fc7.x86_64 the symptoms are back, just as before:
Trying to ifup the device always leads to kernel panic. 

Comment 6 Jost Diederichs 2007-04-01 23:38:09 UTC
Created attachment 151399 [details]
Cumulative r8169.c patch

I found this bug on kernel.org:
http://bugzilla.kernel.org/show_bug.cgi?id=6807
In comment #23 it references a patchkit available at:
http://www.fr.zoreil.com/linux/kernel/2.6.x/2.6.21-rc4/r8169-20070316
it patches r8169.c of kernel source 2.6.20-1.3036.fc7 cleanly. 
So far the results look good. I have done some stress testing and so far not
been able to panic the kernel. 
I'll attach a cumulative patch I built. 
Vaclav, can you test this, too? If you can still get the 1.3036 build you can
simply download the module r8169.ko (x86_64) from
http://the-diederichs.com/downloads/r8169.ko.

Comment 8 Jost Diederichs 2007-04-03 06:52:13 UTC
success.
tested it again with build 1.3036 and more extensively with build 1.3038. 
no problems, thanks

Comment 9 Will Woods 2007-04-03 16:14:49 UTC
Tomas,

Can you try the current rawhide kernel (kernel-2.6.20-1.3040.fc7) and confirm
that it fixes your problem?

Comment 10 Tomas Prochazka 2007-04-05 07:17:26 UTC
I tested with kernel-2.6.20-1.3040.fc7.x86_64.rpm
And stil the same :-( Kernel panic.

I also tried put out cable during booting and activate eth0 manualy after 
system start, the same result.

Comment 11 Jost Diederichs 2007-04-05 14:05:24 UTC
Did you apply the patch from comment 7?
To save some time you can try the compiled module (for build 1.3040.x86_64) from
here:
http://the-diederichs.com/downloads/r8169.ko


Comment 12 Tomas Prochazka 2007-04-05 15:04:08 UTC
No, I used oficial rpm.
Now, I tried yours r8169.ko module and DHCP is working with it.
Great!

Comment 13 Dave Jones 2007-04-23 17:25:35 UTC
this should be fixed in current builds. Please reopen if this isn't the case.



Note You need to log in before you can comment on or make changes to this bug.