Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231258 - Need ability to modify flags while performing 'Change Several Bugs at once' action
Summary: Need ability to modify flags while performing 'Change Several Bugs at once' a...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: devel
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: 4.2-5
Assignee: Simon Green
QA Contact: Matt Tyson 🤬
URL:
Whiteboard:
: 248096 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 02:22 UTC by Chandrasekar Kannan
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-07 02:52:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 281791 None None None Never

Description Chandrasekar Kannan 2007-03-07 02:22:24 UTC
Often, I need to edit the flags field for more than one at a time. 

These fields are not exposed in the "Change several bugs at once UI".
If this is done, then I would be able to edit flags fields for several 
bugs at once.

Comment 2 Jeff Fearn 🐞 2012-05-30 04:37:56 UTC
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 3 Simon Green 2012-06-15 07:35:47 UTC
This would be a really good thing to have. I'm thinking that the interface would list all flags (if any) that ALL bugs can have (there is code already that handles this at a product level and sure about the component level[1]), and obviously the user has the ability to either request or set. Each flag then would have --do_not_change--, X, ?, + and - (depending on the settings of the flag and the users privileges).

[1] flags can be set at the component level, although I'm not aware of any flags in our installation that does this.

  -- simon

Comment 4 Simon Green 2012-06-19 03:20:57 UTC
*** Bug 248096 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Fearn 🐞 2012-06-21 03:53:47 UTC
These bugs have been flagged as still relevant and are being reset to default values for PM consideration.

Comment 8 Simon Green 2012-09-06 01:50:48 UTC
Have submitted patch upstream for this.

  -- simon


Note You need to log in before you can comment on or make changes to this bug.