Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231205 - RFE: Update "GNUPLOT" package to current release 4.2
Summary: RFE: Update "GNUPLOT" package to current release 4.2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuplot
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
: 232351 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 19:07 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-21 13:06:12 UTC


Attachments (Terms of Use)
Specfile for 4.2 release (deleted)
2007-03-27 00:58 UTC, Tim Orling
no flags Details
4.2 release patch to fix X11 font directory references (deleted)
2007-03-27 01:01 UTC, Tim Orling
no flags Details | Diff
Specfile diff for 4.0.0-18 to 4.2.0-0 (deleted)
2007-03-27 04:38 UTC, Tim Orling
no flags Details

Description Joachim Frieben 2007-03-06 19:07:42 UTC
Description of problem:
On March 3, 2007, the latest version 4.2 of the "GNUPLOT" package
has been released upstream. Please update from version 4.0.

Version-Release number of selected component (if applicable):
gnuplot-4.0.0-16.fc7

Comment 1 Ivana Varekova 2007-03-15 09:18:41 UTC
*** Bug 232351 has been marked as a duplicate of this bug. ***

Comment 2 Tim Orling 2007-03-27 00:58:55 UTC
Created attachment 150984 [details]
Specfile for 4.2 release

This specfile has been successfully built on FC5 and FC6 (x86_64).

Comment 3 Tim Orling 2007-03-27 01:01:15 UTC
Created attachment 150985 [details]
4.2 release patch to fix X11 font directory references

4.2 version of refers_to.patch

Comment 4 Tim Orling 2007-03-27 04:38:22 UTC
Created attachment 150999 [details]
Specfile diff for 4.0.0-18 to 4.2.0-0

4.0.0-18-fc7 -> 4.2.0-0 diff

Doesn't directly build ps_symbols.ps (ps_symbols.gpi) without setting
GNUPLOT_PS_DIR to find prologue.ps

Built on FC6 (x86_64).

Comment 5 Gwyn Ciesla 2007-03-29 17:03:19 UTC
Is there a timetable to this being pushed to devel?  I'm curious if this will
fix this:https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233143 and the bug
it blocks.

Comment 6 Marcin Garski 2007-03-30 19:52:33 UTC
4.2 should fix bug #135239

Comment 7 Terje Røsten 2007-05-08 09:17:51 UTC
Any news here?
Would be great to have 4.2 in Fedora 7.

Comment 8 Terje Røsten 2007-05-09 17:26:12 UTC
Added Tim's nice patches and then some:

- use major/minor variables
- set GNUPLOT_PS_DIR to build
- set installdir for gnuplot.cfg explicit
- add fontconfig to buildreq

RPMS for FC5 and FC6 on i386 and x86_64, SRPMS and spec file
available here:

  http://web.phys.ntnu.no/~terjeros/gnuplot/

Untested.



Comment 9 Ivana Varekova 2007-05-21 13:06:12 UTC
Fixed in gnuplot-4.2.0-1.fc8.


Note You need to log in before you can comment on or make changes to this bug.