Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231147 - Kerberos double logging
Summary: Kerberos double logging
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 434858
TreeView+ depends on / blocked
 
Reported: 2007-03-06 15:18 UTC by Basil
Modified: 2008-02-25 21:04 UTC (History)
1 user (show)

Fixed In Version: 1.6.3-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-25 20:56:57 UTC


Attachments (Terms of Use)

Description Basil 2007-03-06 15:18:11 UTC
Description of problem:

The KDC (krb5kdc), kadmin daemon (kadmind), and libraries create duplicate log
entries when using /etc/krb5.conf as a configuration source. Each logged event
is recorded twice.

Steps to Reproduce:
1. Install krb5-server
2. make sure /etc/krb5.conf contains a logging stanza that looks something like:

[logging]
 default = FILE:/var/log/krb5libs.log
 kdc = FILE:/var/log/krb5kdc.log
 admin_server = FILE:/var/log/kadmind.log

3. Start the KDC: 'service krb5kdc start'

Actual results:
/var/log/krb5kdc.log will show double entries, i.e. each line is duplicated. e.g

Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750

... and so on.

Expected results:

A single line for each entry, like so:

Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750


Additional info:

After some investigation in the MIT krb5-bugs mailing list, it appears that is
is due to passing certain configure options to the package (probably
--sysconfdir=/etc is to blame). A temporary solution is to add the line

export KRB5_CONFIG=/etc/krb5.conf

to /etc/sysconfig/krb5kdc and /etc/sysconfig/kadmin

The discussion that helped me figure this out:
http://mailman.mit.edu/pipermail/krb5-bugs/2005-December/thread.html#4134

-Basil.

Comment 1 Nalin Dahyabhai 2008-02-25 20:56:57 UTC
Fixing in 1.6.3-8.


Note You need to log in before you can comment on or make changes to this bug.