Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231145 - gtk-window-decorator and gnome-terminal crash on xorg-x11-server-1.2.99.901-1.fc7
Summary: gtk-window-decorator and gnome-terminal crash on xorg-x11-server-1.2.99.901-1...
Keywords:
Status: CLOSED DUPLICATE of bug 231170
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 15:12 UTC by sangu
Modified: 2018-04-11 08:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 20:44:20 UTC


Attachments (Terms of Use)
/var/log/Xorg.0.log (deleted)
2007-03-06 15:12 UTC, sangu
no flags Details

Description sangu 2007-03-06 15:12:10 UTC
Description of problem:
gtk-window-decorator and gnome-terminal crash on xorg-x11-server-1.2.99.901-1.fc7

The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 498 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1986 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Version-Release number of selected component (if applicable):
1.2.99.901-1.fc7


How reproducible:
always

Steps to Reproduce:
1. update xorg-x11-server-1.2.99.901-1.fc7
2. start Xserver
3. start gnome-terminal
  
Actual results:


Expected results:


Additional info:
gnome-terminal-2.17.92-1.fc7
compiz-0.3.6-2.fc7

vga nvidia 6800GS
vga driver version : nvidia proprietary driver-1.0-9746

Comment 1 sangu 2007-03-06 15:12:11 UTC
Created attachment 149340 [details]
/var/log/Xorg.0.log

Comment 2 sangu 2007-03-20 03:42:51 UTC
cairo version is 1.4.0-1.fc7 in rawhide.
Please see : https://bugs.freedesktop.org/show_bug.cgi?id=10250#c13

Comment 3 Matěj Cepl 2007-03-20 20:44:20 UTC

*** This bug has been marked as a duplicate of 231170 ***


Note You need to log in before you can comment on or make changes to this bug.