Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231133 - user bitlbee not created
Summary: user bitlbee not created
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bitlbee
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 13:19 UTC by Matěj Cepl
Modified: 2018-04-11 07:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 07:48:16 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2007-03-06 13:19:47 UTC
Description of problem:
When switching bitlbee to using bitlbee user, it would be actually useful to
create one.

Version-Release number of selected component (if applicable):
bitlbee-1.0.3-5.fc6

How reproducible:
100%

Steps to Reproduce:
1.start with fresh install of RHEL5/FC6
2.install bitlbee and enable it in /etc/xinetd.d/bitlbee
3.telnet localhost 6667
  
Actual results:
nothing
message in /var/log/messages saying that
Mar  6 14:13:25 hubmaier xinetd[2115]: Unknown user: bitlbee [file=/etc/xinetd.d
/bitlbee] [line=9]
Mar  6 14:13:25 hubmaier xinetd[2115]: Error parsing attribute user - DISABLING 
SERVICE [file=/etc/xinetd.d/bitlbee] [line=9]


Expected results:
sensible reply from bitlbee server and no warnings in /var/log/messages

Additional info:

Comment 1 Matěj Cepl 2007-03-06 13:46:59 UTC
And of course, rights on /var/lib/bitlbee were messed up too (it should be IMHO
700 bitlbee:root, not 700 root:bitlbee).

Comment 2 Robert Scheck 2007-03-06 14:41:02 UTC
That's *very* strange, because you're the first one reporting this. Can you 
please execute /usr/sbin/getenforce to ensure, that it's not a SELinux problem?

Can you also please copy the output of "rpm -V bitlbee" here into? It looks 
like your system is messed up, because the correct permissions of /var/lib/
bitlbee would be 700 bitlbee:bitlbee.

Finally, can you verify whether /usr/sbin/useradd exists and whether the shadow-
utils is not broken ("rpm -V shadow-utils")? I'm guessing the wrong permissions 
are caused by the errornously not created bitlbee user which IMHO must be the 
result of a partitially broken package or even system.

Comment 3 Robert Scheck 2007-03-08 20:17:32 UTC
This bug report could be related to https://www.redhat.com/archives/fedora-
devel-list/2007-March/msg00394.html, if no further information are provided.

Comment 4 Matěj Cepl 2007-03-09 00:31:08 UTC
Robert, this is not correct URL -- the one your provided points to the problems
of glibc and fakeroot. How does it relate to this bug?

Otherwise,

[matej@chelcicky h_office]\$ rpm -V bitlbee
S.5....T c /etc/xinetd.d/bitlbee
[matej@chelcicky h_office]\$ ssh hubmaier
Last login: Thu Mar  8 22:11:17 2007 from adsl2071.in.ipex.cz
[matej@hubmaier ~]\$ rpm -V bitlbee
S.5....T c /etc/xinetd.d/bitlbee
[matej@hubmaier ~]\$ rpm -V shadow 
balíček shadow není nainstalován
[matej@hubmaier ~]\$ man getenforce
[matej@hubmaier ~]\$ getenforce
Permissive
[matej@hubmaier ~]\$ rpm -V shadow-utils
..?..... c /etc/default/useradd
S.?.....   /usr/sbin/groupadd
S.?.....   /usr/sbin/groupdel
S.?.....   /usr/sbin/groupmod
S.?.....   /usr/sbin/useradd
S.?.....   /usr/sbin/userdel
S.?.....   /usr/sbin/usermod
[matej@hubmaier ~]\$ uname -a
Linux hubmaier 2.6.18-8.el5xen #1 SMP Fri Jan 26 14:29:35 EST 2007 x86_64 x86_64
x86_64 GNU/Linux
[matej@hubmaier ~]\$ 

Let me emphasize that it is x86_64, so it may be slightly weird somewhere.

Comment 5 Robert Scheck 2007-03-09 06:41:31 UTC
Hmm...unknown user bitlbee would mean that "/usr/sbin/useradd -r -s /sbin/
nologin -d /var/lib/bitlbee -M -c "BitlBee User" bitlbee" would have been 
failed. Do you have a bitlbee user for now or what happens at your system
when the command gets executed again?

I recognized x86_64, but from what I can see currently it doesn't look bitlbee 
related.



Comment 6 Matěj Cepl 2007-03-09 13:25:37 UTC
I have created bitlbee user manually of course and now everything works just fine.

Comment 7 Robert Scheck 2007-03-11 01:48:15 UTC
I've written https://www.redhat.com/archives/fedora-extras-list/2007-March/
msg00168.html to search for maybe other reproducers in the Fedora world. The 
people I know using bitlbee at ix86, x86_64 or ppc didn't have this problem.

Comment 8 Gwyn Ciesla 2007-03-11 01:59:01 UTC
Attempted, FC6, cannot reproduce.  SELinux is permissive, it that helps.

Comment 9 Michael Schwendt 2007-03-11 02:09:39 UTC
What does /var/log/secure say about the attempt at running useradd
to create the bitlbee user? There should be a log entry for the time
the rpm was installed.


Comment 10 Matěj Cepl 2007-03-12 12:57:52 UTC
Michael,

[matej@hubmaier ~]\$ sudo grep bitlbee /var/log/secure*
/var/log/secure:Mar 12 13:57:08 hubmaier sudo:    matej : TTY=pts/2 ;
PWD=/home/matej ; USER=root ; COMMAND=/bin/grep bitlbee /var/log/secure
/var/log/secure.1
/var/log/secure.1:Mar  6 13:15:23 hubmaier sudo:    matej : TTY=pts/0 ;
PWD=/home/matej ; USER=root ; COMMAND=/usr/bin/yum install bitlbee
/var/log/secure.1:Mar  6 14:24:20 hubmaier sudo:    matej : TTY=pts/0 ;
PWD=/var/lib ; USER=root ; COMMAND=/bin/chmod g+w bitlbee/
/var/log/secure.1:Mar  6 14:24:29 hubmaier sudo:    matej : TTY=pts/0 ;
PWD=/var/lib ; USER=root ; COMMAND=/bin/chmod g+wx bitlbee/
/var/log/secure.1:Mar  6 14:24:37 hubmaier sudo:    matej : TTY=pts/0 ;
PWD=/var/lib ; USER=root ; COMMAND=/bin/chmod g+rwx bitlbee/
/var/log/secure.1:Mar  6 14:30:56 hubmaier sudo:    matej : TTY=pts/3 ;
PWD=/home/matej ; USER=bitlbee ; COMMAND=/usr/sbin/bitlbee
/var/log/secure.1:Mar  6 14:31:26 hubmaier sudo:    matej : TTY=pts/3 ;
PWD=/home/matej ; USER=bitlbee ; COMMAND=/usr/sbin/bitlbee --help
/var/log/secure.1:Mar  6 14:31:42 hubmaier sudo:    matej : TTY=pts/3 ;
PWD=/home/matej ; USER=bitlbee ; COMMAND=/usr/sbin/bitlbee -v -n
/var/log/secure.1:Mar  6 14:33:57 hubmaier useradd[2547]: new group:
name=bitlbee, GID=106
/var/log/secure.1:Mar  6 14:33:57 hubmaier useradd[2547]: new user:
name=bitlbee, UID=100, GID=106, home=/usr/sbin/, shell=/sbin/nologin
/var/log/secure.1:Mar  6 14:34:53 hubmaier sudo:    matej : TTY=pts/3 ;
PWD=/home/matej ; USER=bitlbee ; COMMAND=/usr/sbin/bitlbee -v -n
/var/log/secure.1:Mar  6 14:35:43 hubmaier sudo:    matej : TTY=pts/3 ;
PWD=/var/lib ; USER=bitlbee ; COMMAND=/usr/sbin/bitlbee -v -n
[matej@hubmaier ~]\$ 

which means that the only creation of bitlbee user was done by me by hand.

Comment 11 Robert Scheck 2007-03-26 18:52:11 UTC
As far as I can see, nobody is able to reproduce this problem including myself; 
one possible cause is https://www.redhat.com/archives/fedora-extras-list/2007-
March/msg00171.html, but I'm likely to close this bug report (unfortunately not 
with a real fix).

Comment 12 Matěj Cepl 2007-03-27 07:48:16 UTC
I don't think there was pre-existing bitlbee group -- this was really fresh
install of new system. However, as I cannot reproduce it, let it be WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.