Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231103 - system-config-lvm doesn't ask for the root password
Summary: system-config-lvm doesn't ask for the root password
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-lvm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 03:44 UTC by William Lovaton
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-21 19:13:52 UTC


Attachments (Terms of Use)

Description William Lovaton 2007-03-06 03:44:01 UTC
Description of problem:
When launching s-c-lvm as a normal user it doesn't ask for the root password
like the other s-c-* tools.  It just shows and error window that says "Unknown
error".  Executing it as the root user works fine.


Version-Release number of selected component (if applicable):
Fedora 7 Test 2 installation from LiveCD with all of the updates available as of
today:
system-config-lvm-1.0.18-1.2.FC6


How reproducible:
As a normal user go to System -> Administration -> s-c-lvm
or
As a normal user execute system-config-lvm on a terminal window

  
Actual results:
Error window saying "Unknown error".


Expected results:
system-config-lvm should ask me for the root password and starts properly.

Comment 1 Jim Parsons 2007-03-06 14:43:53 UTC
Yikes - this is a terrible regression. looking into it...

Comment 2 Stanko Kupcevic 2007-03-06 14:49:48 UTC
Probably a duplicate of bz170632, have to verify

Comment 3 William Lovaton 2007-03-30 19:06:01 UTC
This bug is still present in Fedora 7 Test 3 Live CD.  It's not that critical
but still annoying.

Comment 4 William Lovaton 2007-04-28 12:24:35 UTC
Still happening in Test 4 (updated through yum).

Comment 5 William Lovaton 2007-05-21 19:13:52 UTC
This is fixed in the last update (system-config-lvm-1.1.1-1.0.fc7).  Thanks.


Note You need to log in before you can comment on or make changes to this bug.