Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231081 - PATA_ALI: Secondary channel CDROM not found during install
Summary: PATA_ALI: Secondary channel CDROM not found during install
Keywords:
Status: CLOSED DUPLICATE of bug 227207
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 00:08 UTC by Larry K. Brown
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 10:35:33 UTC


Attachments (Terms of Use)
Boot messages from offending computer (deleted)
2007-03-07 21:25 UTC, Larry K. Brown
no flags Details

Description Larry K. Brown 2007-03-06 00:08:19 UTC
Description of problem:
Can not install because driver for CDROM not found.  Fedora Core 6 works on
this laptop but Fedora Core 7 test 2 does not.  Under FC6 it uses the ide_cd
and the cdrom drivers.  The CDROM is a UJDA720 DVD/CDRW drive on a KDS laptop.

Version-Release number of selected component (if applicable):


How reproducible:
I tried every driver in the list but none would work.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alan Cox 2007-03-07 19:36:45 UTC
Can you attach your FC6 boot messages so I can see what hardware you have and
how it is configured when working.


Comment 2 Larry K. Brown 2007-03-07 21:25:07 UTC
Created attachment 149497 [details]
Boot messages from offending computer

Comment 3 Larry K. Brown 2007-03-07 21:27:42 UTC
Comment on attachment 149497 [details]
Boot messages from offending computer

I burned this file to CD from FC6 through GNOME also.

Comment 4 Vegard Lima 2007-03-17 21:07:47 UTC
Have similar problem with the FC7 test 2 live cd on my laptop.
lspci -v:
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4) (prog-if 8a [Master
SecP Pri P])

The failure message is something like this:

ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cms a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: soft resetting port

Hope that helps.

Comment 5 Alan Cox 2007-03-28 14:46:43 UTC
Test patch posted to linux-kernel list


Comment 6 Vegard Lima 2007-03-29 15:05:26 UTC
Applied this patch: http://lkml.org/lkml/2007/3/27/172
to 2.6.21-rc5-mm2. Got exactly the same error message.
Then removed the cdrom. Then it says:

ata2: BUG: prereset() requested invalid reset type

The kernel then proceeds to panic as it can't find root filesystem.


Comment 7 Matthew Miller 2007-04-10 15:57:28 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 8 Alan Cox 2007-04-19 10:35:33 UTC

*** This bug has been marked as a duplicate of 227207 ***


Note You need to log in before you can comment on or make changes to this bug.