Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231079 - Running "cat /proc/net/anycast6" causes a reference leak
Summary: Running "cat /proc/net/anycast6" causes a reference leak
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lalancette
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 23:09 UTC by Chris Lalancette
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 19:18:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Simple patch to correctly "put" ipv6 device (deleted)
2007-03-05 23:11 UTC, Chris Lalancette
no flags Details | Diff

Description Chris Lalancette 2007-03-05 23:09:31 UTC
Description of problem:
Running "cat /proc/net/anycast6" in the current RHEL-5 current causes a
reference leak, where we do an "in6_dev_get", but never a "in6_dev_put" in
ac6_get_first().  This results in ethernet devices that cannot be removed with
rmmod, and requires a reboot to fix.  The solution is from an upstream patch here:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=aa6e4a96e7589948fe770744f7bb4f0f743dddaa

which just adds the in6_dev_put.

Comment 1 Chris Lalancette 2007-03-05 23:11:23 UTC
Created attachment 149304 [details]
Simple patch to correctly "put" ipv6 device

Comment 2 Andy Gospodarek 2007-03-07 19:18:46 UTC

*** This bug has been marked as a duplicate of 231310 ***


Note You need to log in before you can comment on or make changes to this bug.