Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231078 - up2date RPM 'post' scriptlet has a dependancy on /sbin/restorecon
Summary: up2date RPM 'post' scriptlet has a dependancy on /sbin/restorecon
Keywords:
Status: CLOSED DUPLICATE of bug 201020
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 23:06 UTC by Brian Reichert
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-06 20:23:59 UTC


Attachments (Terms of Use)

Description Brian Reichert 2007-03-05 23:06:15 UTC
Description of problem:

up2date RPM 'post' scriptlet has a dependancy on /sbin/restorecon.  This is
provided by the 'policycoreutils' RPM.

If this RPM is not installed, you get postinstall errors.
  

Version-Release number of selected component (if applicable):
  
  gnupg-1.2.6-6.i386.rpm


How reproducible:

  very


Steps to Reproduce:
1.  install the above RPM, without policycoreutils-1.18.1-4.9.i386.rpm installed
2.
3.
  
Actual results:

# rpm -i *.rpm
warning: gnupg-1.2.6-6.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
/var/tmp/rpm-tmp.15748: line 11: restorecon: command not found
error: %post(up2date-4.4.69-25.i386) scriptlet failed, exit status 127


Expected results:

# rpm -i gnupg-1.2.6-6.i386.rpm 
warning: gnupg-1.2.6-6.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e



Additional info:

Comment 1 Pradeep Kilambi 2007-03-06 15:01:56 UTC
This bug has been resolved for 4.5 in the following bug#:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201020

Comment 2 Pradeep Kilambi 2007-03-06 20:23:59 UTC

*** This bug has been marked as a duplicate of 201020 ***


Note You need to log in before you can comment on or make changes to this bug.