Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231063 - No device found, with Broadcom Corporation BCM4310 in FC6
Summary: No device found, with Broadcom Corporation BCM4310 in FC6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2007-03-05 21:40 UTC by Ney Senna
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-17 06:00:37 UTC


Attachments (Terms of Use)

Description Ney Senna 2007-03-05 21:40:00 UTC
Description of problem:
FC6 don't show device wi-fi Broadcom Corporation BCM4310, with bcm43xx
I use notebook Compaq NX6320.
If i use another distro (live) in this notebook, no problems found -> no
problems with hardware.

If i use ndiswrapper, then show the wi-fi, but can't connect with wpa_supplicant
I have others notebooks, and connect with wpa_supplicant intel 2200 (driver
ipw2200) -> no problems with ap.

Steps to Reproduce:
1. Install FC6 with kernel 2.6.18-1.2869.fc6
2. modprobe bcm43xx
3. when i enter : iwconfig 
lo        no wireless extensions.
eth0      no wireless extensions.
sit0      no wireless extensions.

Additional info:

#lsmod |grep bcm
bcm43xx               425153  0
ieee80211softmac       36801  1 bcm43xx
ieee80211              34953  2 bcm43xx,ieee80211softmac

lspci -vv
08:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 01)
        Subsystem: Hewlett-Packard Company Unknown device 1361
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at e8000000 (32-bit, non-prefetchable) [disabled]
[size=16K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
        Capabilities: [58] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
                Address: 00000000  Data: 0000
        Capabilities: [d0] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <4us, L1 unlimited
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
                Link: Latency L0s <4us, L1 <64us
                Link: ASPM L0s Enabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x1

Comment 1 Chuck Ebbert 2007-03-06 14:30:55 UTC
Please try a recent kernel.

Comment 2 Ney Senna 2007-03-06 15:38:30 UTC
i try with 2.6.19-1.2911, but don't work. The problem is the same.

Comment 3 Chuck Ebbert 2007-03-06 15:47:13 UTC
Latest kernel is 2.6.19-1.2911.6.5


Comment 4 Jon Stanley 2008-01-08 01:55:39 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 5 Ney Senna 2008-01-08 13:03:47 UTC
I use ndiswrapper and have sucess to connect with wpa2 personal and enterprise.



Note You need to log in before you can comment on or make changes to this bug.