Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231046 - zdump on x86_64 segfaults
Summary: zdump on x86_64 segfaults
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc
Version: 4.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 20:09 UTC by David Mack
Modified: 2016-11-24 14:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-23 09:10:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Mack 2007-03-05 20:09:18 UTC
Description of problem:
-bash-3.00$ uname -a
Linux uls-shell 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 
x86_64 GNU/Linux
-bash-3.00$ /usr/sbin/zdump -v /etc/localtime
Segmentation fault

This happens on both RHEL4 and RHEL3. As a result, I can't determine if the 
machines in question need to be patched for the DST change on Sunday.




Version-Release number of selected component (if applicable):
-bash-3.00$ /usr/sbin/zdump --version
@(#)zdump.c     7.40


How reproducible:
/usr/sbin/zdump -v /usr/share/zoneinfo/America/Los_Angeles 
Segmentation fault

/usr/sbin/zdump -v /etc/localtime
Segmentation fault

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Not a segfault?

Additional info:

Comment 1 Lilish Saki 2007-03-07 02:00:26 UTC
Hello:

I also noticed this today after applying patches on x86_64- RHEL3Update4 systems
Description:
============
For amd64 of WS/AS of RHEL3 U4, I get segmentation fault as following: 
 
machine1(root)# zdump -v /etc/localtime
Segmentation fault
machine1(root)# zdump -v America/Los_Angeles | grep 2007 jaguar1(root)# rpm -qa
| grep tzdata
tzdata-2005m-1.EL3 
 
Things I tried: 
 
1) Did rpm -Uvh tzdata*.rpm --force to update tzdata rpm. 
2) cp /usr/share/zoneinfo/America/Los_Angeles /etc/localtime
3) Tried another updated tzdata rpm and still get segmentation fault 
 
machine2(root)# rpm -qa | grep tzdata
tzdata-2006a-1.EL3
machine2(root)# zdump -v /etc/localtime
Segmentation fault 
 
I dont see anything on doing below: 
 
machine1(root)# zdump -v America/Los_Angeles | grep 2007 
 
 
**What is wrong here? Is something corrupted? 
 
 
Following are machine arch/kernel type : 
 
--------------
machine2(root)# cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 4) lynx28(root)# uname -a
Linux lynx28 2.4.21-27.ELsmp #1 SMP Wed Dec 1 21:53:57 EST 2004 x86_64 x86_64
x86_64 GNU/Linux
----------------
machine1(root)# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 4) jaguar1(root)# uname -r
2.4.21-27.ELsmp jaguar1(root)# uname -a Linux jaguar1 2.4.21-27.ELsmp #1 SMP Wed
Dec 1 21:53:57 EST 2004 x86_64 x86_64 x86_64 GNU/Linux
---------------- 
 
 


(In reply to comment #0)
> Description of problem:
> -bash-3.00$ uname -a
> Linux uls-shell 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 
> x86_64 GNU/Linux
> -bash-3.00$ /usr/sbin/zdump -v /etc/localtime
> Segmentation fault
> 
> This happens on both RHEL4 and RHEL3. As a result, I can't determine if the 
> machines in question need to be patched for the DST change on Sunday.
> 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> -bash-3.00$ /usr/sbin/zdump --version
> @(#)zdump.c     7.40
> 
> 
> How reproducible:
> /usr/sbin/zdump -v /usr/share/zoneinfo/America/Los_Angeles 
> Segmentation fault
> 
> /usr/sbin/zdump -v /etc/localtime
> Segmentation fault
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> Not a segfault?
> 
> Additional info:



Comment 2 Jakub Jelinek 2007-03-13 08:01:23 UTC
Can't reproduce this, neither in RHEL3 nor in RHEL4 with the above mentioned
tzdata packages.
Unless the tzdata package you have installed is corrupted (please
rpm -V tzdata
) or unless /etc/localtime is corrupted (cmp /etc/localtime
/usr/share/zoneinfo/America/Los_Angeles), zdump should really depend just on
the data files and nothing else.
You can try to install glibc-debuginfo and run zdump under gdb to see where
it segfaults, get a backtrace etc.


Note You need to log in before you can comment on or make changes to this bug.