Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231045 - zdump on x86_64 segfaults
Summary: zdump on x86_64 segfaults
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tzdata
Version: 4.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 20:05 UTC by David Mack
Modified: 2015-05-05 01:33 UTC (History)
1 user (show)

Fixed In Version: RHEL4-U4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 12:12:01 UTC


Attachments (Terms of Use)

Description David Mack 2007-03-05 20:05:19 UTC
Description of problem:
-bash-3.00$ uname -a
Linux uls-shell 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 
x86_64 GNU/Linux
-bash-3.00$ /usr/sbin/zdump -v /etc/localtime
Segmentation fault

This happens on both RHEL4 and RHEL3. As a result, I can't determine if the 
machines in question need to be patched for the DST change on Sunday.




Version-Release number of selected component (if applicable):
-bash-3.00$ /usr/sbin/zdump --version
@(#)zdump.c     7.40


How reproducible:
/usr/sbin/zdump -v /usr/share/zoneinfo/America/Los_Angeles 
Segmentation fault

/usr/sbin/zdump -v /etc/localtime
Segmentation fault

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Not a segfault?

Additional info:

Comment 1 Petr Machata 2007-03-07 12:12:01 UTC
This seems to be fixed in RHEL-3 (bug 146210), and I see the fix was commited to
RHEL-4 glibc almost a year ago.  Updating glibc packages should help.


Note You need to log in before you can comment on or make changes to this bug.